Bug 23881 - SVG Renderers are missing proper clippedOverflowRectForRepaint implementations
Summary: SVG Renderers are missing proper clippedOverflowRectForRepaint implementations
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 11981 (view as bug list)
Depends on: 25276
Blocks: 14015 16188 19366 20769 21968 25403 25404
  Show dependency treegraph
 
Reported: 2009-02-10 15:30 PST by Eric Seidel (no email)
Modified: 2010-07-08 02:22 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2009-02-10 15:30:18 PST
SVG Renderers are missing proper clippedOverflowRectForRepaint implementations

This causes all of our scrolling and invalidation bugs for SVG.

I'm going to make this bug the "master" and relate all of the "dupes" of this.
Comment 1 Eric Seidel (no email) 2009-02-10 15:32:05 PST
I've related the 5 I found.  I bet there are probably 5 more dupes of this in bugs.webkit.org somewhere. :)
Comment 2 Eric Seidel (no email) 2009-04-17 10:12:18 PDT
Huzzah!  I think all these bugs will probably be fixed by the patch attached to:
https://bugs.webkit.org/show_bug.cgi?id=25268
(Which is patch 7 in a 10 patch "fix the darn SVG rendering tree finally" series.)
Comment 3 Eric Seidel (no email) 2009-04-28 14:43:14 PDT
All of the SVG renderers at least have decent implementations as part of bug 25431.  They're still not respecting clips though (bug 14015) thus we're overpainting some.
Comment 4 Eric Seidel (no email) 2009-04-28 16:44:17 PDT
*** Bug 11981 has been marked as a duplicate of this bug. ***
Comment 5 Nikolas Zimmermann 2010-07-08 02:22:02 PDT
No more overpainting, all our repaint rects are clipped against all resources (masker, clipper, etc..)