Bug 216921 - Support for web-platform-tests crashtests
Summary: Support for web-platform-tests crashtests
Status: RESOLVED DUPLICATE of bug 209649
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL: https://web-platform-tests.org/writin...
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-24 03:08 PDT by Frédéric Wang (:fredw)
Modified: 2020-09-24 09:30 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frédéric Wang (:fredw) 2020-09-24 03:08:47 PDT
Follow-up of the discussion of https://bugs.webkit.org/show_bug.cgi?id=186045#c77

A new concept of "crashtest" was introduced in WPT (last year maybe?). I'm not exactly sure about the details and how we handle them in WebKit, but I'm opening this to track any work needed, if we are interested in supporting this. The doc is https://web-platform-tests.org/writing-tests/crashtest.html ; basically the idea is just to load a test page and the test pass iff the page does not crash.

Some quick summary of TODO things:

* Adjust the importer. I'm just importing my recent crashtests in bug 216871 and I see the test files are just treated as "resource files".

* Adjust the runner, to be more robust with how we handle crashing test (see bug 186045 comment 80).

* Add support for "test-wait" class, which should just be refactoring the logic for reftest-wait (see bug 186045 comment 82). If we don't do that, we could easily have false positive PASS results since we would close the test page before the full testing is performed.
Comment 1 Sam Sneddon [:gsnedders] 2020-09-24 09:30:23 PDT

*** This bug has been marked as a duplicate of bug 209649 ***