Bug 216256 - [WinCairo] ASSERTION FAILED: isStartOfParagraph(startOfParagraphToMove) in editing/inserting/insert-list-user-select-none-crash.html
Summary: [WinCairo] ASSERTION FAILED: isStartOfParagraph(startOfParagraphToMove) in ed...
Status: RESOLVED DUPLICATE of bug 118740
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on: 118740
Blocks:
  Show dependency treegraph
 
Reported: 2020-09-07 18:22 PDT by Fujii Hironori
Modified: 2021-01-08 12:19 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fujii Hironori 2020-09-07 18:22:34 PDT
[WinCairo] ASSERTION FAILED: isStartOfParagraph(startOfParagraphToMove) in editing/inserting/insert-list-user-select-none-crash.html

WinCairo Debug WK1 and WK2

https://build.webkit.org/builders/WinCairo%2064-bit%20WKL%20Debug%20%28Tests%29/builds/3376

  editing/inserting/insert-list-user-select-none-crash.html [ Crash ]

stderr:
ASSERTION FAILED: isStartOfParagraph(startOfParagraphToMove)
C:\BW\wincairo-wkl-debug\build\Source\WebCore\editing/CompositeEditCommand.cpp(1392) : WebCore::CompositeEditCommand::moveParagraph
1   00007FF8FF9E1D7A WTFCrash
2   00007FF8E6F5AE51 WTFCrashWithInfo
3   00007FF8E9955E8B WebCore::CompositeEditCommand::moveParagraph
4   00007FF8E99FA7EC WebCore::InsertListCommand::listifyParagraph
5   00007FF8E99F9615 WebCore::InsertListCommand::doApplyForSingleParagraph
6   00007FF8E99F86C6 WebCore::InsertListCommand::doApply
7   00007FF8E9950495 WebCore::CompositeEditCommand::apply
8   00007FF8E99D82BA WebCore::executeInsertOrderedList
9   00007FF8E99BDA47 WebCore::Editor::Command::execute
10  00007FF8E9685039 WebCore::Document::execCommand
11  00007FF8E7C3ED8F WebCore::jsDocumentPrototypeFunctionExecCommandBody
12  00007FF8E7C4C10F WebCore::IDLOperation<WebCore::JSDocument>::call<&WebCore::jsDocumentPrototypeFunctionExecCommandBody,0>
13  00007FF8E7C22869 WebCore::jsDocumentPrototypeFunctionExecCommand
14  0000023516CF11BE
Comment 1 Fujii Hironori 2020-09-07 18:24:09 PDT
The same assertion faiure was reported in GTK port. However, GTK buildbot isn't failing.

Bug 202900 – Chromium test-case asserts with ASSERTION FAILED: isStartOfParagraph(startOfParagraphToMove)
Comment 3 Fujii Hironori 2021-01-08 12:19:43 PST
Fixed in r271316.

*** This bug has been marked as a duplicate of bug 118740 ***