Bug 211612 - REGRESSION(r261341): imported/w3c/web-platform-tests/html/semantics/embedded-content/the-video-element/intrinsic_sizes.htm is failing
Summary: REGRESSION(r261341): imported/w3c/web-platform-tests/html/semantics/embedded-...
Status: RESOLVED CONFIGURATION CHANGED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Eric Carlson
URL:
Keywords: InRadar
: 211611 (view as bug list)
Depends on: 211641
Blocks:
  Show dependency treegraph
 
Reported: 2020-05-07 21:15 PDT by Lauro Moura
Modified: 2020-05-08 15:47 PDT (History)
6 users (show)

See Also:


Attachments
Patch (1.68 KB, patch)
2020-05-08 10:05 PDT, Eric Carlson
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lauro Moura 2020-05-07 21:15:45 PDT
Diff:

--- /home/slave/webkitgtk/gtk-linux-64-release-tests/build/layout-test-results/imported/w3c/web-platform-tests/html/semantics/embedded-content/the-video-element/intrinsic_sizes-expected.txt
+++ /home/slave/webkitgtk/gtk-linux-64-release-tests/build/layout-test-results/imported/w3c/web-platform-tests/html/semantics/embedded-content/the-video-element/intrinsic_sizes-actual.txt
@@ -5,6 +5,6 @@
 PASS default object size is 300x150 
 PASS default height is half the width 
 PASS default width is twice the height 
-FAIL default object size after src is removed assert_equals: expected "300px" but got "320px"
+PASS default object size after src is removed 
 FAIL default object size after poster is removed assert_equals: expected "102px" but got "300px"
Comment 2 Aakash Jain 2020-05-08 05:12:34 PDT
r261341 (Bug 211464) seems like the commit which made this test very flaky.

It did made following changed in imported/w3c/web-platform-tests/html/semantics/embedded-content/the-video-element/intrinsic_sizes-expected.txt

- FAIL default object size after src is removed assert_equals: expected "320px" but got "300px"
+ FAIL default object size after src is removed assert_equals: expected "300px" but got "320px"
Comment 3 Radar WebKit Bug Importer 2020-05-08 09:38:01 PDT
<rdar://problem/63024081>
Comment 4 Eric Carlson 2020-05-08 10:05:11 PDT
Created attachment 398868 [details]
Patch
Comment 5 EWS 2020-05-08 10:30:39 PDT
Committed r261392: <https://trac.webkit.org/changeset/261392>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 398868 [details].
Comment 6 Ryan Haddad 2020-05-08 13:25:43 PDT
Re-opened since this is blocked by bug 211641
Comment 7 Ryan Haddad 2020-05-08 13:27:52 PDT
Reverted r261341 and r261392 for reason:

Caused multiple regression test failures

Committed r261409: <https://trac.webkit.org/changeset/261409>
Comment 8 Alexey Proskuryakov 2020-05-08 15:47:55 PDT
*** Bug 211611 has been marked as a duplicate of this bug. ***