Bug 20129 - Cursor position in empty editable element does not respect padding
Summary: Cursor position in empty editable element does not respect padding
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords: HasReduction
: 20242 21785 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-07-22 03:00 PDT by Torsten Radtke
Modified: 2014-01-03 07:36 PST (History)
7 users (show)

See Also:


Attachments
Test case XML file (135 bytes, application/xml)
2008-07-22 03:00 PDT, Torsten Radtke
no flags Details
Test case CSS file (250 bytes, text/plain)
2008-07-22 03:01 PDT, Torsten Radtke
no flags Details
reduction (248 bytes, text/html)
2012-05-01 21:54 PDT, Ryosuke Niwa
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Torsten Radtke 2008-07-22 03:00:17 PDT
The position of the cursor when clicking on an empty element filled with the :empty:before CSS rule ignores the CSS padding property. It is always drawn in the top left corner of the box. See the attached files for an example.
Comment 1 Torsten Radtke 2008-07-22 03:00:53 PDT
Created attachment 22423 [details]
Test case XML file
Comment 2 Torsten Radtke 2008-07-22 03:01:31 PDT
Created attachment 22425 [details]
Test case CSS file
Comment 3 Ryosuke Niwa 2012-05-01 21:54:33 PDT
Created attachment 139743 [details]
reduction
Comment 4 Alexey Proskuryakov 2012-05-02 12:54:44 PDT
See also: bug 20242, bug 21785.
Comment 5 gur.trio 2013-12-18 03:16:50 PST
(In reply to comment #0)
> The position of the cursor when clicking on an empty element filled with the :empty:before CSS rule ignores the CSS padding property. It is always drawn in the top left corner of the box. See the attached files for an example.

Latest webkit and chrome its working. Please confirm so that we can close this.
Comment 6 Ryosuke Niwa 2013-12-24 00:11:12 PST
Works as expected now.
Comment 7 gur.trio 2013-12-24 00:56:46 PST
*** Bug 21785 has been marked as a duplicate of this bug. ***
Comment 8 gur.trio 2013-12-24 00:58:01 PST
*** Bug 20242 has been marked as a duplicate of this bug. ***
Comment 9 Torsten Radtke 2014-01-03 07:36:02 PST
Works as expected in Safari Version 7.0.1 (9537.73.11)