Bug 20242 - On pageload, cursor position in an empty contenteditable element doesn't respect text-indent
: On pageload, cursor position in an empty contenteditable element doesn't resp...
Status: RESOLVED DUPLICATE of bug 20129
Product: WebKit
Classification: Unclassified
Component: CSS
: 528+ (Nightly build)
: All All
: P2 Normal
Assigned To: Nobody
: HasReduction
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-31 08:31 PDT by Torsten Radtke
Modified: 2014-01-03 07:39 PST (History)
3 users (show)

See Also:


Attachments
Test case XML file (178 bytes, application/xml)
2008-07-31 08:31 PDT, Torsten Radtke
no flags Details
Test case CSS file (224 bytes, text/plain)
2008-07-31 08:32 PDT, Torsten Radtke
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Torsten Radtke 2008-07-31 08:31:09 PDT
The position of the cursor when clicking on an empty element filled with the
:empty:before CSS rule ignores the CSS text-indent property. It is always drawn as if text-indent was 0. See the attached files for an example.
Comment 1 Torsten Radtke 2008-07-31 08:31:55 PDT
Created attachment 22577 [details]
Test case XML file
Comment 2 Torsten Radtke 2008-07-31 08:32:21 PDT
Created attachment 22578 [details]
Test case CSS file
Comment 3 Tab Atkins 2011-10-20 17:29:43 PDT
Looks like a clearcut QoI bug.  Here's a smaller testcase:

<!DOCTYPE html>
<p style="height: 50px; border: thin solid black; text-indent: 20px;" contenteditable></p>

When the page first loads, the cursor is at the left edge of the <p>.  As soon as you type anything, even if you then delete it, the cursor jumps to 20px away from the edge, respecting the text-indent.
Comment 4 Alexey Proskuryakov 2012-05-02 12:55:08 PDT
See also: bug 20129, bug 20242.
Comment 5 gur.trio 2013-12-18 03:15:59 PST
(In reply to comment #4)
> See also: bug 20129, bug 20242.

Latest webkit and chrome its working. Please confirm so that we can close this.
Comment 6 gur.trio 2013-12-24 00:58:01 PST

*** This bug has been marked as a duplicate of bug 20129 ***
Comment 7 Torsten Radtke 2014-01-03 07:39:20 PST
Works as expected in Safari Version 7.0.1 (9537.73.11)