Bug 21785 - Not possible to put the cursor inside an empty editable inline element styled with the :empty:before CSS rule
Summary: Not possible to put the cursor inside an empty editable inline element styled...
Status: RESOLVED DUPLICATE of bug 20129
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-22 00:29 PDT by Torsten Radtke
Modified: 2014-01-03 07:43 PST (History)
2 users (show)

See Also:


Attachments
Test case XML file (187 bytes, application/xml)
2008-10-22 00:30 PDT, Torsten Radtke
no flags Details
Test case CSS file (347 bytes, text/plain)
2008-10-22 00:31 PDT, Torsten Radtke
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Torsten Radtke 2008-10-22 00:29:14 PDT
It is not possible to put the cursor inside an empty editable element that is styled with the :empty:before CSS rule and display style "inline" in r37764. If the display style is set to block, the cursor can be placed inside the element. See the attached files for an example.
Comment 1 Torsten Radtke 2008-10-22 00:30:40 PDT
Created attachment 24551 [details]
Test case XML file
Comment 2 Torsten Radtke 2008-10-22 00:31:11 PDT
Created attachment 24552 [details]
Test case CSS file
Comment 3 Alexey Proskuryakov 2009-02-03 01:53:36 PST
See also: bug 15256.
Comment 4 Alexey Proskuryakov 2012-05-02 12:54:52 PDT
See also: bug 20129, bug 21785.
Comment 5 gur.trio 2013-12-18 03:17:10 PST
(In reply to comment #4)
> See also: bug 20129, bug 21785.

Latest webkit and chrome its working. Please confirm so that we can close this.
Comment 6 gur.trio 2013-12-24 00:56:46 PST

*** This bug has been marked as a duplicate of bug 20129 ***
Comment 7 Torsten Radtke 2014-01-03 07:43:10 PST
Works as expected in Safari Version 7.0.1 (9537.73.11)