Bug 192065 - Flaky Test: webgl/1.0.2/conformance/more/functions/bindBufferBadArgs.html
Summary: Flaky Test: webgl/1.0.2/conformance/more/functions/bindBufferBadArgs.html
Status: RESOLVED DUPLICATE of bug 192050
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: WebKit Commit Bot
URL:
Keywords:
Depends on:
Blocks: 50856
  Show dependency treegraph
 
Reported: 2018-11-27 18:38 PST by WebKit Commit Bot
Modified: 2018-12-01 16:05 PST (History)
4 users (show)

See Also:


Attachments
Archive of layout-test-results from webkit-cq-03 (2.50 MB, application/zip)
2018-11-27 18:38 PST, WebKit Commit Bot
no flags Details
Archive of layout-test-results from webkit-cq-02 (2.55 MB, application/zip)
2018-11-29 02:25 PST, WebKit Commit Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Commit Bot 2018-11-27 18:38:51 PST
This is an automatically generated bug from the commit-queue.
webgl/1.0.2/conformance/more/functions/bindBufferBadArgs.html has been flaky on the commit-queue.

webgl/1.0.2/conformance/more/functions/bindBufferBadArgs.html was authored by roger_fong@apple.com.
https://trac.webkit.org/browser/trunk/LayoutTests/webgl/1.0.2/conformance/more/functions/bindBufferBadArgs.html

The commit-queue just saw webgl/1.0.2/conformance/more/functions/bindBufferBadArgs.html flake (DumpRenderTree crashed) while processing attachment 355832 [details] on bug 192060.
Bot: webkit-cq-03  Port: <class 'webkitpy.common.config.ports.MacPort'>  Platform: Mac OS X 10.12.6

The bots will update this with information from each new failure.

If you believe this bug to be fixed or invalid, feel free to close.  The bots will re-open if the flake re-occurs.

If you would like to track this test fix with another bug, please close this bug as a duplicate.  The bots will follow the duplicate chain when making future comments.
Comment 1 WebKit Commit Bot 2018-11-27 18:38:52 PST
Created attachment 355836 [details]
Archive of layout-test-results from webkit-cq-03
Comment 2 Ryan Haddad 2018-11-28 12:51:25 PST
Thread 43 Crashed:: DFG Worklist Worker Thread
0   com.apple.JavaScriptCore      	0x000000010c5caf15 JSC::speculationFromValue(JSC::JSValue) + 213 (SpeculatedType.cpp:477)
1   com.apple.JavaScriptCore      	0x000000010c59ec16 JSC::CodeBlock::valueProfilePredictionForBytecodeOffset(JSC::ConcurrentJSLocker const&, int) + 38 (SpeculatedType.h:473)
2   com.apple.JavaScriptCore      	0x000000010c6a451a JSC::DFG::ByteCodeParser::getPredictionWithoutOSRExit(unsigned int) + 90 (DFGByteCodeParser.cpp:837)
3   com.apple.JavaScriptCore      	0x000000010c694c0e void JSC::DFG::ByteCodeParser::parseGetById<JSC::OpGetById>(JSC::Instruction const*) + 126 (DFGByteCodeParser.cpp:889)
4   com.apple.JavaScriptCore      	0x000000010c683fd4 JSC::DFG::ByteCodeParser::parseBlock(unsigned int) + 5588 (Instruction.h:45)
5   com.apple.JavaScriptCore      	0x000000010c6986ea JSC::DFG::ByteCodeParser::parseCodeBlock() + 810 (DFGByteCodeParser.cpp:7037)
6   com.apple.JavaScriptCore      	0x000000010c698a83 JSC::DFG::ByteCodeParser::parse() + 83 (DFGByteCodeParser.cpp:6852)
7   com.apple.JavaScriptCore      	0x000000010c699be8 JSC::DFG::parse(JSC::DFG::Graph&) + 392 (DFGByteCodeParser.cpp:93)
8   com.apple.JavaScriptCore      	0x000000010c7fdde2 JSC::DFG::Plan::compileInThreadImpl() + 338 (DFGPlan.cpp:251)
9   com.apple.JavaScriptCore      	0x000000010c7fd58b JSC::DFG::Plan::compileInThread(JSC::DFG::ThreadData*) + 619 (DFGPlan.cpp:188)
10  com.apple.JavaScriptCore      	0x000000010c84af95 JSC::DFG::Worklist::ThreadBody::work() + 277 (DumbPtrTraits.h:41)
11  com.apple.JavaScriptCore      	0x000000010c19a9fe WTF::Function<void ()>::CallableWrapper<WTF::AutomaticThread::start(WTF::AbstractLocker const&)::$_0>::call() + 334 (AutomaticThread.cpp:224)
12  com.apple.JavaScriptCore      	0x000000010c1dc044 WTF::Thread::entryPoint(WTF::Thread::NewThreadContext*) + 212 (memory:2735)
13  com.apple.JavaScriptCore      	0x000000010c1ddbe9 WTF::wtfThreadEntryPoint(void*) + 9 (ThreadingPthreads.cpp:203)
14  libsystem_pthread.dylib       	0x00007fffb76ea93b _pthread_body + 180
15  libsystem_pthread.dylib       	0x00007fffb76ea887 _pthread_start + 286
16  libsystem_pthread.dylib       	0x00007fffb76ea08d thread_start + 13
Comment 3 WebKit Commit Bot 2018-11-29 02:25:09 PST
The commit-queue just saw webgl/1.0.2/conformance/more/functions/bindBufferBadArgs.html flake (DumpRenderTree crashed) while processing attachment 355987 [details] on bug 192092.
Bot: webkit-cq-02  Port: <class 'webkitpy.common.config.ports.MacPort'>  Platform: Mac OS X 10.12.6
Comment 4 WebKit Commit Bot 2018-11-29 02:25:10 PST
Created attachment 355994 [details]
Archive of layout-test-results from webkit-cq-02
Comment 5 Alexey Proskuryakov 2018-12-01 16:05:14 PST

*** This bug has been marked as a duplicate of bug 192050 ***