Bug 188779 - Support "name" option for dedicated workers
Summary: Support "name" option for dedicated workers
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Yusuke Suzuki
URL:
Keywords: InRadar
: 172016 (view as bug list)
Depends on:
Blocks: 164678
  Show dependency treegraph
 
Reported: 2018-08-20 23:02 PDT by Yusuke Suzuki
Modified: 2018-08-21 21:59 PDT (History)
13 users (show)

See Also:


Attachments
Patch (39.66 KB, patch)
2018-08-20 23:09 PDT, Yusuke Suzuki
no flags Details | Formatted Diff | Diff
Patch (39.69 KB, patch)
2018-08-20 23:12 PDT, Yusuke Suzuki
no flags Details | Formatted Diff | Diff
Patch (42.20 KB, patch)
2018-08-21 00:25 PDT, Yusuke Suzuki
joepeck: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yusuke Suzuki 2018-08-20 23:02:30 PDT
Support "name" option for dedicated workers
Comment 1 Yusuke Suzuki 2018-08-20 23:09:34 PDT
Created attachment 347613 [details]
Patch
Comment 2 Build Bot 2018-08-20 23:12:11 PDT
Attachment 347613 [details] did not pass style-queue:


ERROR: Source/WebCore/workers/service/context/ServiceWorkerThread.cpp:75:  Missing spaces around :  [whitespace/init] [4]
Total errors found: 1 in 18 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Yusuke Suzuki 2018-08-20 23:12:31 PDT
Created attachment 347614 [details]
Patch
Comment 4 Build Bot 2018-08-20 23:15:12 PDT
Attachment 347614 [details] did not pass style-queue:


ERROR: Source/WebCore/workers/service/context/ServiceWorkerThread.cpp:75:  Missing spaces around :  [whitespace/init] [4]
Total errors found: 1 in 18 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 5 Yusuke Suzuki 2018-08-21 00:25:39 PDT
Created attachment 347618 [details]
Patch
Comment 6 Yusuke Suzuki 2018-08-21 00:27:59 PDT
*** Bug 172016 has been marked as a duplicate of this bug. ***
Comment 7 Build Bot 2018-08-21 00:28:08 PDT
Attachment 347618 [details] did not pass style-queue:


ERROR: Source/WebCore/workers/service/context/ServiceWorkerThread.cpp:75:  Missing spaces around :  [whitespace/init] [4]
Total errors found: 1 in 19 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 8 Joseph Pecoraro 2018-08-21 11:22:33 PDT
Comment on attachment 347618 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=347618&action=review

r=me!

> Source/WebCore/ChangeLog:14
> +        [2]: https://bugs.webkit.org/show_bug.cgi?id=164678

Yep! I have been looking forward to this for a while, thanks!
Comment 9 Joseph Pecoraro 2018-08-21 11:23:46 PDT
Would it be worth a test of our own for Worker names, or should we just rely on the WPTs?
Comment 10 Yusuke Suzuki 2018-08-21 11:27:04 PDT
(In reply to Joseph Pecoraro from comment #9)
> Would it be worth a test of our own for Worker names, or should we just rely
> on the WPTs?

We can add tests additionally! I'll add several ones :)
Comment 11 Yusuke Suzuki 2018-08-21 11:40:08 PDT
Committed r235128: <https://trac.webkit.org/changeset/235128>
Comment 12 Radar WebKit Bug Importer 2018-08-21 11:42:29 PDT
<rdar://problem/43570680>
Comment 13 Truitt Savell 2018-08-21 14:05:37 PDT
The new test:
http/wpt/workers/name-property-enhanced.html

From patch:
<https://trac.webkit.org/changeset/235128>

Is flakey and failed on most builds:
https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=http%2Fwpt%2Fworkers%2Fname-property-enhanced.html
Comment 14 Joseph Pecoraro 2018-08-21 14:29:51 PDT
> Is flakey and failed on most builds:
> https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.
> html#showAllRuns=true&tests=http%2Fwpt%2Fworkers%2Fname-property-enhanced.
> html

Thanks for the heads up.

Do you file bugzilla bugs on these failures? What is the failure diff? It requires a lot of clicks from the slow loading flakiness dashboard to act!
Comment 15 Joseph Pecoraro 2018-08-21 14:31:54 PDT
Looks like the failure is out of order results:
https://build.webkit.org/results/Apple%20Sierra%20Release%20WK1%20(Tests)/r235128%20(12237)/results.html

> --- /Volumes/Data/slave/sierra-release-tests-wk1/build/layout-test-results/http/wpt/workers/name-property-enhanced-expected.txt
> +++ /Volumes/Data/slave/sierra-release-tests-wk1/build/layout-test-results/http/wpt/workers/name-property-enhanced-actual.txt
> @@ -2,7 +2,7 @@
>  Harness Error (FAIL), message = 2 duplicate test names: "name property value for DedicatedWorkerGlobalScope", "name property is replaceable for DedicatedWorkerGlobalScope"
>  
>  PASS name property value for DedicatedWorkerGlobalScope 
> -PASS name property is replaceable for DedicatedWorkerGlobalScope 
>  PASS name property value for DedicatedWorkerGlobalScope 
>  PASS name property is replaceable for DedicatedWorkerGlobalScope 
> +PASS name property is replaceable for DedicatedWorkerGlobalScope
Comment 16 Joseph Pecoraro 2018-08-21 14:33:19 PDT
Maybe in WPT fetch_tests_from_worker(...) might run tests in parallel instead of serial?
Comment 17 Ryan Haddad 2018-08-21 19:04:07 PDT
This test is failing more often than it is passing on the bots and is slowing down EWS.

We should roll this out if it needs more investigation.
Comment 18 Ryan Haddad 2018-08-21 19:22:54 PDT
Reverted r235128 for reason:

The test added with this change is frequently failing.

Committed r235155: <https://trac.webkit.org/changeset/235155>
Comment 19 Yusuke Suzuki 2018-08-21 21:58:32 PDT
Committed r235159: <https://trac.webkit.org/changeset/235159>
Comment 20 Yusuke Suzuki 2018-08-21 21:59:14 PDT
Thanks, I've relanded the patch by splitting the test into 2 files to make it deterministic!