Bug 18147 - REGRESSION (Safari 3-3.1): Can't Download or Save Images
Summary: REGRESSION (Safari 3-3.1): Can't Download or Save Images
Status: RESOLVED DUPLICATE of bug 26881
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 525.x (Safari 3.1)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: Regression
: 18763 18764 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-03-27 09:44 PDT by Ben Mills
Modified: 2009-10-20 23:37 PDT (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Mills 2008-03-27 09:44:53 PDT
While in web inspector when viewing images you can no longer click and drag images to a folder (Ex: your desktop) to save them. Also right clicking on the image brings up the contextual menu with: Open Image in New Window, Download Image, Copy Image, and Inspect Element. The only menu item of those listed that works is Inspect Element. In all versions of Safari 3.0 it worked flawlessly. In Safari 3.1 and confirmed in the latest WebKit builds this functionality has been broken.
Comment 1 Matt Lilek 2008-04-27 11:25:31 PDT
*** Bug 18763 has been marked as a duplicate of this bug. ***
Comment 2 Timothy Hatcher 2008-05-25 14:02:11 PDT
*** Bug 18764 has been marked as a duplicate of this bug. ***
Comment 3 Ben Mills 2008-06-10 11:11:05 PDT
Webkit nightly build r34469 has fixed the ability to drag drop to save images. Copy image still copies a flattened version of transparent images. The "Download Image" option remains broken.
Comment 4 Joseph Pecoraro 2009-10-20 23:37:27 PDT
The Right Click Context Menu is a well known problem. I'm using bug 26881 as the umbrella for Right-Click issues.

The other aspect of this bug, click + drag, works in the current build that I'm testing r49845 and I haven't noticed any problems before.

*** This bug has been marked as a duplicate of bug 26881 ***