Bug 18763 - Download Image does not work from web inspector
Summary: Download Image does not work from web inspector
Status: RESOLVED DUPLICATE of bug 18147
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://webkit.org/
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-26 21:30 PDT by Gavin Sherlock
Modified: 2008-04-27 11:25 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gavin Sherlock 2008-04-26 21:30:13 PDT
1.  Go to bug url (though as far as I can tell, this is true for any url where there are images on the page)
2.  Right-click anywhere on the page, and select Inspect Element.
3.  In the web inspector, click on resources
4.  Click on download.png in the left hand column
5.  Right click on the image in the central pane, and select "Download image"

Expected results:

Image will be downloaded to default downloads folder, or a file save dialog will come up.

Actual Results:

Nothing happens.

Tested with r32531, but same behavior also exists in Safari Version 3.1.1 (5525.18).  Not sure if it is a regression from an earlier version.  Tested on 10.5.2
Comment 1 Matt Lilek 2008-04-27 11:25:31 PDT

*** This bug has been marked as a duplicate of 18147 ***