Bug 17997 - Full Page Zoom: Artifacts in background images on mooseyard.com
Summary: Full Page Zoom: Artifacts in background images on mooseyard.com
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Minor
Assignee: Dave Hyatt
URL: http://mooseyard.com/Jens/
Keywords:
: 17999 18003 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-03-21 17:26 PDT by Frederik De Bleser
Modified: 2008-11-11 11:51 PST (History)
3 users (show)

See Also:


Attachments
Screenshot of the site showing tearing artefacts (662.95 KB, image/png)
2008-03-21 17:27 PDT, Frederik De Bleser
no flags Details
This is a workaround patch. Just recording it. (1.27 KB, patch)
2008-03-24 19:41 PDT, Dave Hyatt
no flags Details | Formatted Diff | Diff
Patch (2.12 KB, patch)
2008-11-11 11:28 PST, Dave Hyatt
sullivan: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Frederik De Bleser 2008-03-21 17:26:41 PDT
Using the new full page zoom feature in Webkit r31201, zooming twice on the page http://mooseyard.com/Jens/ (command-+ command-+) shows tearing artefacts between repeating background images, manifested as black lines. See the screenshot for details.

Note that this happens only at some zoom levels, notably zoomed in twice and five times. Zooming out also results in artefacts.
Comment 1 Frederik De Bleser 2008-03-21 17:27:21 PDT
Created attachment 19947 [details]
Screenshot of the site showing tearing artefacts
Comment 2 Dave Hyatt 2008-03-21 23:28:09 PDT
*** Bug 18003 has been marked as a duplicate of this bug. ***
Comment 3 Dave Hyatt 2008-03-21 23:28:52 PDT
*** Bug 17999 has been marked as a duplicate of this bug. ***
Comment 4 Dave Hyatt 2008-03-21 23:29:32 PDT
This bug appears to be Leopard-only, and it's an issue with

CGContextDrawTiledImage

The old Tiger code path (although slower) seems to be correct.
Comment 5 Dave Hyatt 2008-03-21 23:47:10 PDT
I can actually work around this, but it would mean taking the slow code path (and I think it would hurt performance way too much for zoomed pages to do this).

Comment 6 Dave Hyatt 2008-03-24 19:41:37 PDT
Created attachment 20018 [details]
This is a workaround patch.  Just recording it.
Comment 7 Dave Hyatt 2008-11-11 11:28:48 PST
Created attachment 25047 [details]
Patch
Comment 8 John Sullivan 2008-11-11 11:41:56 PST
Comment on attachment 25047 [details]
Patch

Do you also want to check PLATFORM(MAC) anywhere? I see the existing #ifndef BUILDING_ON_TIGER does not do so, but maybe it should?

John
Comment 9 Dave Hyatt 2008-11-11 11:51:56 PST
Fixed in r38309.

Good question about PLATFORM(MAC).  It depends on what version of CG ends up
shipping with the next version of Safari on Windows whether or not the
workaround will be needed for Windows.