Bug 173433 - REGRESSION(r218344): [WPE] Thousands of layout test crashes
Summary: REGRESSION(r218344): [WPE] Thousands of layout test crashes
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WPE WebKit (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Carlos Alberto Lopez Perez
URL:
Keywords:
Depends on: 173483
Blocks: 173061
  Show dependency treegraph
 
Reported: 2017-06-15 14:13 PDT by Carlos Alberto Lopez Perez
Modified: 2017-06-19 06:09 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Alberto Lopez Perez 2017-06-15 14:13:15 PDT
r218344 <http://trac.webkit.org/changeset/218344> caused thousands of layout test crashes due to the update on WPEBackend-mesa on the JHBuild.

My guess is that something is setting a DISPLAY environment there (perhaps the tool driver) and confusing the check for X11.

The bot itself doesn't set that variable.

https://build.webkit.org/builders/WPE%20Linux%2064-bit%20Release%20%28Tests%29/builds/874/steps/layout-test/logs/stdio
Comment 1 Carlos Alberto Lopez Perez 2017-06-15 14:19:20 PDT
Committed r218355: <http://trac.webkit.org/changeset/218355>
Comment 2 Carlos Alberto Lopez Perez 2017-06-15 17:59:22 PDT
I reverted the update on WPEBackend-mesa that triggered this issue. Layout tests are working back as expected on WPE.


Also I identified the issue: we are setting always a DISPLAY environment variable on Tools/Scripts/webkitpy/port/base.py (even when the user environment doesn't have one).


I will upload ASAP a patch to fix this.
Comment 3 Carlos Alberto Lopez Perez 2017-06-16 11:44:08 PDT
Proposed patch at: bug 173483
Comment 4 Carlos Alberto Lopez Perez 2017-06-19 06:09:54 PDT
Committed r218491: <http://trac.webkit.org/changeset/218491>