Bug 170556 - REGRESSION (r209882): Web Inspector: Console's filter bar has text search field, but the next/previous buttons don't do anything
Summary: REGRESSION (r209882): Web Inspector: Console's filter bar has text search fie...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Nikita Vasilyev
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-04-06 11:04 PDT by Brian Burg
Modified: 2017-04-19 16:41 PDT (History)
5 users (show)

See Also:


Attachments
Patch (2.46 KB, patch)
2017-04-19 13:24 PDT, Nikita Vasilyev
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Burg 2017-04-06 11:04:59 PDT
We should remove these until we plan to actually make this a find bar instead of a filter bar (e.g., https://bugs.webkit.org/show_bug.cgi?id=164847).
Comment 1 Radar WebKit Bug Importer 2017-04-06 11:05:35 PDT
<rdar://problem/31481755>
Comment 2 Nikita Vasilyev 2017-04-18 16:48:18 PDT
This broke in https://trac.webkit.org/changeset/209882/webkit.
Comment 3 Nikita Vasilyev 2017-04-18 17:11:32 PDT
From UserInterface/Views/FindBanner.js:

    set numberOfResults(numberOfResults)
    {
        if (numberOfResults === undefined || isNaN(numberOfResults))
            numberOfResults = null;

        this._numberOfResults = numberOfResults;

        this._previousResultButton.disabled = this._nextResultButton.disabled = (numberOfResults <= 0);


It appears that when searching in Console tab, next/previous buttons of an instance of WebInspector.FindBanner gets disabled as expected. That problem is that it's a wrong instance of WebInspector.FindBanner, one that isn't even attached to the DOM.

    this._previousResultButton.parentNode // null
Comment 4 Nikita Vasilyev 2017-04-18 18:38:33 PDT
My comment above might be unrelated to this bug.

See https://bugs.webkit.org/show_bug.cgi?id=164047#c10 for the cause of this regression.
Comment 5 Nikita Vasilyev 2017-04-19 13:24:33 PDT
Created attachment 307503 [details]
Patch
Comment 6 Matt Baker 2017-04-19 16:16:56 PDT
Comment on attachment 307503 [details]
Patch

r=me
Comment 7 WebKit Commit Bot 2017-04-19 16:41:22 PDT
Comment on attachment 307503 [details]
Patch

Clearing flags on attachment: 307503

Committed r215543: <http://trac.webkit.org/changeset/215543>
Comment 8 WebKit Commit Bot 2017-04-19 16:41:24 PDT
All reviewed patches have been landed.  Closing bug.