Bug 16847 - Bugzilla should send pages as UTF-8
Summary: Bugzilla should send pages as UTF-8
Status: RESOLVED DUPLICATE of bug 17457
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Website (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://bugs.webkit.org/show_bug.cgi?i...
Keywords:
: 18772 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-11 15:23 PST by Eric Seidel (no email)
Modified: 2009-07-01 08:30 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2008-01-11 15:23:42 PST
Bugzilla should send pages at UTF8

Mark mentioned in 
http://bugs.webkit.org/show_bug.cgi?id=13167#c4
that he should fix this.  It looks like this hasn't quite been done yet.  This bug is to track the fix to bugzilla (or to upgrade to a version of bugzilla which sends pages as utf8).
Comment 1 Mark Rowe (bdash) 2008-01-12 02:24:04 PST
It's nowhere near as simple as it seems.  The old version of Bugzilla we have is completely retarded and store the text in the database in whatever encoding their browser happened to be using when they wrote the comment.  This means the Bugzilla database currently contains a horrible mess of text in latin1, MacRoman, UTF-8 and other codecs.  There is a script that in theory can convert all of these to UTF-8 when upgrading to Bugzilla 3, but in my tests it did a less than perfect job.
Comment 2 Alexey Proskuryakov 2008-01-12 14:35:31 PST
Will it be possible to manually force another charset to see old comments stored as Latin-1? If so, I'm not sure that we spend much time trying to fix old data.

Also, does having invalid UTF-8 in the database cause internal problems in Bugzilla 3?
Comment 3 Robert Blaut 2008-07-25 14:12:24 PDT
*** Bug 18772 has been marked as a duplicate of this bug. ***
Comment 4 David Kilzer (:ddkilzer) 2009-07-01 08:29:57 PDT
The contrib/recode.pl script that comes with recent versions of Bugzilla updates the previous text in the database to be UTF-8 encoded, and then serves the web pages as UTF-8 encoded as well.  Bugzilla also handles the encoding on the initial submit as well.

I'm changing this to be a duplicate of the Bugzilla upgrade bug (Bug 17457) since it will get fixed in the upgrade process.


*** This bug has been marked as a duplicate of 17457 ***