Bug 17457 - Upgrade to Bugzilla 3.2.x
: Upgrade to Bugzilla 3.2.x
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: WebKit Website
: 523.x (Safari 3)
: Macintosh Mac OS X 10.5
: P2 Normal
Assigned To: Nobody
http://www.bugzilla.org/
:
Depends on:
Blocks: BugzillaSummaryEdit 26958
  Show dependency treegraph
 
Reported: 2008-02-20 13:35 PST by David Kilzer (:ddkilzer)
Modified: 2009-07-03 18:46 PDT (History)
10 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2008-02-20 13:35:13 PST
Now that bugs.webkit.org is in Subversion, we can upgrade to Bugzilla 3.0.x fairly easily.
Comment 1 David Kilzer (:ddkilzer) 2008-02-20 13:35:40 PST
*** Bug 17456 has been marked as a duplicate of this bug. ***
Comment 2 David Kilzer (:ddkilzer) 2008-04-13 18:18:32 PDT
I've started working on merging BugsSite to Bugzilla 3.0.3.

Comment 3 David Kilzer (:ddkilzer) 2008-04-18 19:30:11 PDT
Status:  I've got everything merged except for the custom templates.
Comment 4 David Kilzer (:ddkilzer) 2008-04-27 08:24:44 PDT
(In reply to comment #3)
> Status:  I've got everything merged except for the custom templates.

Also have to merge the custom skins files yet.

Note that there were 222 custom template files (the entire template/en/default directory was apparently copied to template/en/custom), only 46 of which had any differences from their default versions.  Need to go through those diffs individually to find out which ones are really needed.

Comment 5 Eric Seidel 2009-06-08 13:45:06 PDT
I assume work on this has stopped (since there haven't been updates in a year).  Maybe I can be of help?  I would like to be able to write scripts which use the bugzilla API... but that's only available in 3.x :(
Comment 6 David Kilzer (:ddkilzer) 2009-06-08 22:45:41 PDT
(In reply to comment #5)
> I assume work on this has stopped (since there haven't been updates in a year).
>  Maybe I can be of help?  I would like to be able to write scripts which use
> the bugzilla API... but that's only available in 3.x :(

Nope, I've been busy working on products announced at WWDC this week.  I plan to work on this next week.
Comment 7 Jon@Chromium 2009-06-29 13:58:30 PDT
How is this going?
Comment 8 Mark Rowe (bdash) 2009-06-29 14:00:17 PDT
Very well.
Comment 9 David Kilzer (:ddkilzer) 2009-06-29 14:25:07 PDT
(In reply to comment #8)
> Very well.

I've got Bugzilla merged to 3.2.3 in a local git repository as of this morning.  Just have to work out the UTF-8 encodings update for the database and tweak the UI to only partially suck after the update (I'll let others tweak it more after it lands if they so choose).
Comment 10 David Kilzer (:ddkilzer) 2009-07-01 08:27:26 PDT
I've got the UI fixed up (mostly tweaks to the top of the page) and the contrib/recode.pl script fixed to work around Bug 9630 that caused a number of 0xA0 characters to be submitted to the bugs.webkit.org database.  (It seems that using an initial encoding of cp1252 magically converts them back to normal spaces in UTF-8.)  Only had to manually specify the encoding (shiftjis in this case) for 6 items in the database as the script guessed the rest using the Encode::Detect module.

Just need to schedule some down time for the upgrade.
Comment 11 David Kilzer (:ddkilzer) 2009-07-01 08:29:57 PDT
*** Bug 16847 has been marked as a duplicate of this bug. ***
Comment 12 David Kilzer (:ddkilzer) 2009-07-01 08:30:56 PDT
*** Bug 26883 has been marked as a duplicate of this bug. ***
Comment 13 Eric Seidel 2009-07-01 11:53:38 PDT
Wooohooo!
Comment 15 David Kilzer (:ddkilzer) 2009-07-02 20:15:27 PDT
Check the "From:" address now, Mark!