Bug 165905 - WebAssembly JS API: calling wasm functions with 64-bit parameters / returns
Summary: WebAssembly JS API: calling wasm functions with 64-bit parameters / returns
Status: RESOLVED DUPLICATE of bug 165991
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: JF Bastien
URL:
Keywords:
Depends on:
Blocks: 161709
  Show dependency treegraph
 
Reported: 2016-12-15 10:56 PST by JF Bastien
Modified: 2017-01-12 17:36 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description JF Bastien 2016-12-15 10:56:33 PST
Bug #165902 found that I implemented this wrong. It's valid to export these (because wasm<->wasm supports it) but it's not valid to call them to / from JS:
https://github.com/WebAssembly/design/blob/master/JS.md#tojsvalue

I implemented this wrong in the stubs, and we don't test for it.
Comment 1 Geoffrey Garen 2016-12-20 14:23:03 PST
We think this is probably a dup of bug 165991.
Comment 2 Saam Barati 2017-01-12 17:36:56 PST

*** This bug has been marked as a duplicate of bug 165991 ***