Bug 157736 - AX: Audio and Video elements not accessible via keyboard
Summary: AX: Audio and Video elements not accessible via keyboard
Status: RESOLVED DUPLICATE of bug 117857
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: Safari Technology Preview
Hardware: Macintosh All
: P2 Normal
Assignee: Nobody
URL: http://thepaciellogroup.github.io/AT-...
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2016-05-15 21:00 PDT by David Storey
Modified: 2016-07-20 13:16 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Storey 2016-05-15 21:00:42 PDT
Tests:

http://thepaciellogroup.github.io/AT-browser-tests/test-files/audio.html
http://thepaciellogroup.github.io/AT-browser-tests/test-files/video.html

Steps:

Try to tab to audio or video (possible) then interact with controls (usually tab and arrows in other browsers)

Expected:

To be able to focus controls and interact with them

Actual:

Not possible, unless VoiceOver is running, which you're not likely to be using if you have motor impairments rather than visual.

(apologies if a dupe, but I couldn't find one)
Comment 1 Radar WebKit Bug Importer 2016-05-15 21:01:21 PDT
<rdar://problem/26292931>
Comment 2 Marcy Sutton 2016-05-24 11:25:46 PDT
This is a serious accessibility problem preventing use of the default audio/video player and controls. Until it is fixed, we have to work around it with custom controls...a pretty big failing of otherwise useful HTML5 features.
Comment 3 James Craig 2016-07-20 13:16:15 PDT
This is resolved (partially) in the Sierra betas. Shadow DOM controls now accept keyboard focus from patch to bug 117857, but visible focus is still hidden on a view due to bug 127260.

*** This bug has been marked as a duplicate of bug 117857 ***
Comment 4 James Craig 2016-07-20 13:16:55 PDT
(In reply to comment #3)
> This is resolved (partially) in the Sierra betas. Shadow DOM controls now
> accept keyboard focus from patch to bug 117857, but visible focus is still
> hidden on a view due to bug 127260.

^ on a few.