Bug 155355 - [ARM] REGRESSION(r197994): It made stress/op_add.js and stress/op_sub.js crash
Summary: [ARM] REGRESSION(r197994): It made stress/op_add.js and stress/op_sub.js crash
Status: RESOLVED DUPLICATE of bug 155368
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P1 Critical
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 108645 155164
  Show dependency treegraph
 
Reported: 2016-03-11 02:41 PST by Csaba Osztrogonác
Modified: 2016-03-12 18:18 PST (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2016-03-11 02:41:57 PST
https://trac.webkit.org/changeset/197994 made stress/op_add.js and stress/op_sub.js 
JSC stress tests crash on 32 and 64 bit ARM platforms. At least on Linux, maybe on 
iOS too, but I don't know, because there is no public iOS JSC tester bot.

EFL Linux AArch64 Release
--------------------------
- before: https://build.webkit.org/builders/EFL%20Linux%20AArch64%20Release/builds/5908
- after: https://build.webkit.org/builders/EFL%20Linux%20AArch64%20Release/builds/5909

EFL Linux ARMv7 Thumb2 Release
-------------------------------
- before: https://build.webkit.org/builders/EFL%20Linux%20ARMv7%20Thumb2%20Release/builds/17449
- after: https://build.webkit.org/builders/EFL%20Linux%20ARMv7%20Thumb2%20Release/builds/17450

EFL Linux ARMv7 Traditional Release: no problem on it. ;)

GTK Linux ARM Release (no public info what ARM version)
--------------------------------------------------------
- before: https://build.webkit.org/builders/GTK%20Linux%20ARM%20Release/builds/10531
- after: https://build.webkit.org/builders/GTK%20Linux%20ARM%20Release/builds/10532
  ( not finished yet, maybe it is affected by this bug, maybe not )
Comment 1 Michael Saboff 2016-03-11 07:07:42 PST
We are seeing the same new failures on iOS testing bots.
Comment 2 Alexey Proskuryakov 2016-03-12 18:18:05 PST

*** This bug has been marked as a duplicate of bug 155368 ***