Bug 136632 - Webkitgtk 2.5.3: tarball contains APPLE LICENSE file - stating not distributable
Summary: Webkitgtk 2.5.3: tarball contains APPLE LICENSE file - stating not distributable
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P1 Blocker
Assignee: Nobody
URL:
Keywords:
Depends on: 136943
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-08 08:42 PDT by Dominique Leuenberger
Modified: 2016-12-23 08:31 PST (History)
11 users (show)

See Also:


Attachments
Build WebKitGTK+ 2.4.x without the icons (2.17 KB, patch)
2014-09-17 02:35 PDT, Alberto Garcia
no flags Details | Formatted Diff | Diff
Build WebKitGTK+ 2.5.x without the icons (1.07 KB, patch)
2014-09-17 02:36 PDT, Alberto Garcia
no flags Details | Formatted Diff | Diff
Patch (6.05 KB, patch)
2014-09-19 03:04 PDT, Carlos Garcia Campos
no flags Details | Formatted Diff | Diff
Patch (344.94 KB, patch)
2014-09-19 03:19 PDT, Carlos Garcia Campos
no flags Details | Formatted Diff | Diff
Updated patch (345.59 KB, patch)
2014-09-19 03:55 PDT, Carlos Garcia Campos
gns: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2014-09-08 08:42:33 PDT
During the inclusion into openSUSE, webkitgtk 2.5.3 has been declined by the legal review due to:

Source / WebInspectorUI / APPLE_IMAGES_LICENSE.rtf

The file states:

"""
\f0\b\fs24 \cf0 Apple Inc.\
Software License Agreement for Web Inspector Images\
Internal Use License Only \'96 No Redistribution Permitted\
\
PLEASE READ THIS SOFTWARE LICENSE AGREEMENT ("LICENSE") CAREFULLY BEFORE USING THE APPLE SOFTWARE INCLUDED IN THIS PACKAGE.  BY USING THIS SOFTWARE, YOU ARE AGREEING TO BE BOUND BY THE TERMS OF THIS LICENSE.  IF YOU DO NOT AGREE TO THE TERMS OF THIS LICENSE, DO NOT USE THIS SOFTWARE.\
\pard\pardeftab720\ri0
"""

This does not sound like a license compatible with the spirit of the rest of webkitgtk, which is licensed under GPL, free to redistribution and modification.

(setting severity 'blocker': this blocks inclusion into openSUSE and thus updating GNOME to 3.14)
Comment 1 Alberto Garcia 2014-09-10 04:44:12 PDT
Thanks for the report.

Can anyone from Apple clarify this?
Comment 2 Timothy Hatcher 2014-09-10 08:04:35 PDT
Correct, the images in Source/WebInspectorUI/UserInterface/Images are covered by this license. If you need to redistribute them, please contact me via email at timothy@apple.com for details.
Comment 3 Martin Robinson 2014-09-10 10:25:36 PDT
Bumping this to the highest priority. We should fix our tarball ASAP.
Comment 4 Alberto Garcia 2014-09-11 05:35:19 PDT
(In reply to comment #2)
> Correct, the images in Source/WebInspectorUI/UserInterface/Images
> are covered by this license. If you need to redistribute them,
> please contact me via email at timothy@apple.com for details.

Thanks,

the problem is not that we personally need to redistribute them, but
that license makes them unsuitable for inclusion in the WebKitGTK+
releases.

We need to fix the tarballs and see the implications of this removal.

Adding Emilio to Cc.
Comment 5 Andres Gomez Garcia 2014-09-11 07:00:36 PDT
I will take a look about how to replace the icons ...
Comment 6 Alberto Garcia 2014-09-17 02:35:12 PDT
Created attachment 238245 [details]
Build WebKitGTK+ 2.4.x without the icons

While we are dealing with this, you can remove the affected icons from
the WebKitGTK+ tarball and build it without them.

You can use the attached patch for that (you will also need to run autoreconf).

Of course the inspector is not really usable without the icons, but
everything else should work fine.
Comment 7 Alberto Garcia 2014-09-17 02:36:52 PDT
Created attachment 238246 [details]
Build WebKitGTK+ 2.5.x without the icons

This patch is for the 2.5.x series, which use CMake instead of autotools.
Comment 8 Michael Catanzaro 2014-09-18 17:43:35 PDT
(In reply to comment #6)
> Created an attachment (id=238245) [details]
> While we are dealing with this, you can remove the affected icons from
> the WebKitGTK+ tarball and build it without them.

For Fedora, we're not allowed to use an undistributable tarball at all. We'll have to unpack it, remove the images, apply the patch, and then regenerate the tarball. I know Debian requires this as well. This isn't a huge deal, but if this is going to take some time to resolve, then it'd be very convenient if this could be handled upstream instead.
Comment 9 Carlos Garcia Campos 2014-09-19 00:30:15 PDT
Comment on attachment 238246 [details]
Build WebKitGTK+ 2.5.x without the icons

View in context: https://bugs.webkit.org/attachment.cgi?id=238246&action=review

> Source/WebKit2/PlatformGTK.cmake:-386
> -    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/Images/*.png
> -    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/Images/*.svg

This is not enough, these files are only to make the dependencies in the build system, but what we pass to generate-inspector-gresource-manifest.py is ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/ that is walked finding files with extensions html, js, css, png or svg. So, we need to remove the png and svg extensions from the list of valid extensions in generate-inspector-gresource-manifest.py.
Comment 10 Alberto Garcia 2014-09-19 01:01:20 PDT
(In reply to comment #8)
> For Fedora, we're not allowed to use an undistributable tarball at
> all. We'll have to unpack it, remove the images, apply the patch,
> and then regenerate the tarball. I know Debian requires this as
> well. This isn't a huge deal, but if this is going to take some time
> to resolve, then it'd be very convenient if this could be handled
> upstream instead.

I know, we're dealing with this and will try to release a new tarball
with a new set of images ASAP.
Comment 11 Carlos Garcia Campos 2014-09-19 01:58:40 PDT
(In reply to comment #9)
> (From update of attachment 238246 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=238246&action=review
> 
> > Source/WebKit2/PlatformGTK.cmake:-386
> > -    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/Images/*.png
> > -    ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/UserInterface/Images/*.svg
> 
> This is not enough, these files are only to make the dependencies in the build system, but what we pass to generate-inspector-gresource-manifest.py is ${CMAKE_SOURCE_DIR}/Source/WebInspectorUI/ that is walked finding files with extensions html, js, css, png or svg. So, we need to remove the png and svg extensions from the list of valid extensions in generate-inspector-gresource-manifest.py.

The patch in bug #136943 will make this patch work, and will allow us to ignore the apple icons once we have ours.
Comment 12 Carlos Garcia Campos 2014-09-19 03:04:09 PDT
Created attachment 238365 [details]
Patch

This patch adds free replacements for some of the inspector icons, using the GNOME project as a base and adapted by Andrés for the inspector. It also includes the changes in the makefile and scripts to use the new icons, so that once we have more we only need to upload them.
Comment 13 Carlos Garcia Campos 2014-09-19 03:11:10 PDT
I don't know what it didn't apply, could it be that the EWS were not up to date?
Comment 14 Carlos Garcia Campos 2014-09-19 03:19:54 PDT
Created attachment 238366 [details]
Patch

Ok, I submitted the wrong patch, sorry :-P
Comment 15 Carlos Garcia Campos 2014-09-19 03:55:12 PDT
Created attachment 238371 [details]
Updated patch

Forgot to update also the manifest so that the tarball only includes the free icons
Comment 16 Gustavo Noronha (kov) 2014-09-19 06:18:46 PDT
Comment on attachment 238371 [details]
Updated patch

LGTM
Comment 17 Michael Catanzaro 2014-09-19 07:11:28 PDT
Does the tarball still contain the file APPLE_IMAGES_LICENSE.rtf?
Comment 18 Carlos Garcia Campos 2014-09-19 08:40:22 PDT
Committed r173753: <http://trac.webkit.org/changeset/173753>
Comment 19 Carlos Garcia Campos 2014-09-19 08:41:29 PDT
(In reply to comment #17)
> Does the tarball still contain the file APPLE_IMAGES_LICENSE.rtf?

Good point, I added a rule to the manifest to exclude it as well.
Comment 20 Alberto Garcia 2014-09-29 05:29:19 PDT
Okay, WebKitGTK+ 2.4.6 and 2.6.0 contain a new set of free icons, so we have to tell distributors to upgrade or to replace the icons in the packages they're shipping. I'll write a summary of the situation.
Comment 21 Alberto Garcia 2014-10-01 04:55:34 PDT
Ok, I wrote the summary, thanks everyone for their help!

https://lists.webkit.org/pipermail/webkit-gtk/2014-October/002093.html