Bug 129055 - DFG's own loop analysis should be used for predicting block frequencies instead of relying on LLVM's loop analysis
Summary: DFG's own loop analysis should be used for predicting block frequencies inste...
Status: RESOLVED DUPLICATE of bug 129129
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Filip Pizlo
URL:
Keywords:
Depends on: 129054 129083
Blocks: 112840
  Show dependency treegraph
 
Reported: 2014-02-19 12:21 PST by Filip Pizlo
Modified: 2014-02-23 19:54 PST (History)
10 users (show)

See Also:


Attachments
WRONG PATCH (54.85 KB, patch)
2014-02-19 21:45 PST, Filip Pizlo
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Pizlo 2014-02-19 12:21:17 PST
This is important because our OSR entrypoint transformation makes outer loops sometimes appear as sibling loops, which then messes up a lot of stuff.
Comment 1 Filip Pizlo 2014-02-19 21:45:33 PST
Created attachment 224706 [details]
WRONG PATCH
Comment 2 Filip Pizlo 2014-02-19 21:45:57 PST
Comment on attachment 224706 [details]
WRONG PATCH

Ugh, uploaded to the wrong bug.
Comment 3 Filip Pizlo 2014-02-23 19:54:45 PST

*** This bug has been marked as a duplicate of bug 129129 ***