Bug 127076 - check-webkit-style indentation false alarm in WebKit/win/WebNodeHighlight.cpp
Summary: check-webkit-style indentation false alarm in WebKit/win/WebNodeHighlight.cpp
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 126554 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-01-15 16:57 PST by Brian Burg
Modified: 2014-03-03 05:27 PST (History)
9 users (show)

See Also:


Attachments
Patch (2.34 KB, patch)
2014-02-17 10:29 PST, Laszlo Vidacs
no flags Details | Formatted Diff | Diff
Patch (2.55 KB, patch)
2014-02-26 16:06 PST, Laszlo Vidacs
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Burg 2014-01-15 16:57:01 PST
Found in patch here: https://bugs.webkit.org/show_bug.cgi?id=127068
Comment 1 Csaba Osztrogonác 2014-02-14 07:32:39 PST
The problem is that style-checker thinks if it is a part of a member initialization.

similar problem occured in https://bugs.webkit.org/show_bug.cgi?id=128579
Source/WebCore/platform/graphics/opengl/Extensions3DOpenGL.cpp:239
...
  ::glResolveMultisampleFramebufferAPPLE();
...

https://bugs.webkit.org/show_bug.cgi?id=127068
Source/WebKit/win/WebNodeHighlight.cpp:168:
...
  ::SelectObject(hdc.get(), hbmp.get());
...
Comment 2 Laszlo Vidacs 2014-02-17 10:29:13 PST
Created attachment 224394 [details]
Patch
Comment 3 Ryosuke Niwa 2014-02-26 15:51:23 PST
Comment on attachment 224394 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=224394&action=review

> Tools/ChangeLog:8
> +        Avoid match for ::

Could you describe what the false positive was and what you're changing?
This is too terse of a description.
Comment 4 Laszlo Vidacs 2014-02-26 16:06:44 PST
Created attachment 225315 [details]
Patch
Comment 5 WebKit Commit Bot 2014-02-27 08:56:43 PST
Comment on attachment 225315 [details]
Patch

Clearing flags on attachment: 225315

Committed r164806: <http://trac.webkit.org/changeset/164806>
Comment 6 WebKit Commit Bot 2014-02-27 08:56:46 PST
All reviewed patches have been landed.  Closing bug.
Comment 7 Csaba Osztrogonác 2014-03-03 05:27:46 PST
*** Bug 126554 has been marked as a duplicate of this bug. ***