Bug 126554 - style-bot confused about leading spaces
Summary: style-bot confused about leading spaces
Status: RESOLVED DUPLICATE of bug 127076
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Gergő Balogh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-06 17:08 PST by Brent Fulgham
Modified: 2014-03-03 05:27 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brent Fulgham 2014-01-06 17:08:19 PST
Style bot seems to believe that code like the following is incorrectly indented:

 56: TemporaryOpenGLSetting::~TemporaryOpenGLSetting()
 57: {
 58:     if (m_originalState == m_scopedState)
 59:         return;
 60: 
 61:     if (GL_TRUE == m_originalState)
 62:         ::glEnable(m_capability);
 63:     else
 64:         ::glDisable(m_capability);
 65: }

ERROR: Source/WebCore/platform/graphics/opengl/TemporaryOpenGLSetting.cpp:56:  Wrong number of spaces before statement. (expected: 8)  [whitespace/indent] [4]
ERROR: Source/WebCore/platform/graphics/opengl/TemporaryOpenGLSetting.cpp:56:  Wrong number of spaces before statement. (expected: 8)  [whitespace/indent] [4]

Other code in the same patch is reprimanded with demands that we use two different levels of indentation:

297        ::glStencilMaskSeparate(GL_FRONT, 0xffffffff);
298        clearMask |= GL_STENCIL_BUFFER_BIT;
299    }
300
301    TemporaryOpenGLSetting scopedScissor(GL_SCISSOR_TEST, GL_FALSE);
302    TemporaryOpenGLSetting scopedDither(GL_SCISSOR_TEST, GL_FALSE);
303
304    ::glClear(clearMask);

ERROR: Source/WebCore/platform/graphics/opengl/GraphicsContext3DOpenGLCommon.cpp:301:  Wrong number of spaces before statement. (expected: 8)  [whitespace/indent] [4]
ERROR: Source/WebCore/platform/graphics/opengl/GraphicsContext3DOpenGLCommon.cpp:302:  Wrong number of spaces before statement. (expected: 8)  [whitespace/indent] [4]
ERROR: Source/WebCore/platform/graphics/opengl/GraphicsContext3DOpenGLCommon.cpp:301:  Wrong number of spaces before statement. (expected: 12)  [whitespace/indent] [4]
ERROR: Source/WebCore/platform/graphics/opengl/GraphicsContext3DOpenGLCommon.cpp:302:  Wrong number of spaces before statement. (expected: 12)  [whitespace/indent] [4]
Comment 1 Csaba Osztrogonác 2014-03-03 05:27:46 PST

*** This bug has been marked as a duplicate of bug 127076 ***