Bug 126426 - [GTK] Fails to build if wayland is enabled and X11 is disabled
Summary: [GTK] Fails to build if wayland is enabled and X11 is disabled
Status: RESOLVED DUPLICATE of bug 126927
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-03 02:16 PST by Alberto Garcia
Modified: 2014-01-15 04:26 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alberto Garcia 2014-01-03 02:16:02 PST
If you run configure just with --enable-wayland-target then the X11
target is disabled unless you make it explicit (see bug 121703).

In this case the build fails because all the methods added to
PluginPackageNone.cpp in r159999 (see bug 123997) are already defined
in PluginPackage.cpp, e.g

Source/WebCore/plugins/PluginPackageNone.cpp:72: multiple definition of `_ZN7WebCore13PluginPackageD1Ev'
Source/WebCore/plugins/.libs/libWebCore_la-PluginPackage.o:Source/WebCore/plugins/PluginPackage.cpp:41: first defined here
Comment 1 Alberto Garcia 2014-01-15 04:26:43 PST
Žan also reported this one.

*** This bug has been marked as a duplicate of bug 126927 ***