Bug 123637 - "Unsupported speculation use kind: FinalObject" in FTL::LowerDFGToLLVM::compilePhantom() running v8-v6/v8-crypto.js.default-ftl
Summary: "Unsupported speculation use kind: FinalObject" in FTL::LowerDFGToLLVM::compi...
Status: RESOLVED DUPLICATE of bug 124092
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Filip Pizlo
URL:
Keywords:
Depends on:
Blocks: 112840
  Show dependency treegraph
 
Reported: 2013-11-01 14:43 PDT by Filip Pizlo
Modified: 2013-11-08 18:41 PST (History)
8 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Pizlo 2013-11-01 14:43:52 PDT
...
Comment 1 Filip Pizlo 2013-11-02 11:45:33 PDT
This bug is super elusive.  I can't repro.  It's strange since FinalObjectUse is only used for Identity's that ToThis's are replaced with.
Comment 2 Filip Pizlo 2013-11-08 18:41:20 PST
This bug really represents some weirdness, where even though we didn't see a FinalObjectUse at the point where we decide to start the FTL phases, we end up introducing a FinalObjectUse later.  That shouldn't happen.

But, we won't ever see this bug again after https://bugs.webkit.org/show_bug.cgi?id=124092.  So, I'm marking it as a dupe.

*** This bug has been marked as a duplicate of bug 124092 ***