Bug 11313 - REGRESSION: Textareas do not respond to scroll wheel/trackpad
Summary: REGRESSION: Textareas do not respond to scroll wheel/trackpad
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Major
Assignee: Adele Peterson
URL:
Keywords: HasReduction, InRadar, Regression
: 11578 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-10-15 23:20 PDT by Matt Lilek
Modified: 2006-12-18 17:14 PST (History)
5 users (show)

See Also:


Attachments
testcase (1.52 KB, text/html)
2006-10-15 23:27 PDT, Matt Lilek
no flags Details
patch (what I had) (1.78 KB, patch)
2006-12-12 15:47 PST, Hunter L. Williams
adele: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Lilek 2006-10-15 23:20:20 PDT
Textareas should respond to input from the scroll wheel/track pad but do not in ToT.  Scrolling over a textarea does not move the text at all.  Also, scrolling past a textarea in a page in shipping Safari scrolls the page up to the textarea, scrolls the content in the textarea, then when it reaches the end of the content in the textarea, it continues scrolling the rest of the page - this does not happen in ToT, the textarea simply scrolls by.

Testcase in a minute.
Comment 1 Matt Lilek 2006-10-15 23:27:39 PDT
Created attachment 11108 [details]
testcase
Comment 2 Matt Lilek 2006-10-27 18:00:05 PDT
Filed as <rdar://problem/4808089>
Comment 3 Matt Lilek 2006-11-12 01:11:27 PST
*** Bug 11578 has been marked as a duplicate of this bug. ***
Comment 4 keith 2006-11-12 11:24:01 PST
Any fix for this yet?
Comment 5 Matt Lilek 2006-11-16 15:15:05 PST
This seems to have regressed even further since I first reported it.  Originally, scroll wheel input was ignored, but the scroll bar/arrows on the textbox worked correctly.  Now the scroll bar/arrows are ignored as if they aren't there, the only way to shift what content is displayed in a textarea is to highlight and select up/down.
Comment 6 mitz 2006-11-17 08:46:29 PST
(In reply to comment #5)
> Now the scroll bar/arrows are ignored as if they
> aren't there, the only way to shift what content is displayed in a textarea is
> to highlight and select up/down.

Filed bug 11632 on scrollbars not responding to events since r17770.
Comment 7 Hunter L. Williams 2006-12-12 13:27:35 PST
This appears to be because the code in RenderObject::scroll is not finding the RenderTextControl's internal m_div's layer, but rather is just seeing that RenderTextControl itself has no layer and giving up without scrolling.

I'm not sure what the right fix is here - it seems like overriding |scroll| on RenderTextControl might be safest?  
Comment 8 Geoffrey Garen 2006-12-12 14:14:21 PST
Adele, this looks like a shadow DOM issue.
Comment 9 Dave Hyatt 2006-12-12 14:15:04 PST
Overriding sounds pretty good.  I did something similar for the impl of scrollLeft and scrollTop etc.
Comment 10 Adele Peterson 2006-12-12 14:31:12 PST
I'm rewriting the shadow DOM for this control right now.  I'll work on this after I've checked that in.
Comment 11 Hunter L. Williams 2006-12-12 15:47:49 PST
Created attachment 11827 [details]
patch (what I had)

Hi Adele, in case it helps here's what I had for this.
Comment 12 Adele Peterson 2006-12-12 15:58:07 PST
Comment on attachment 11827 [details]
patch (what I had)

actually that looks nice and easy to merge with what I have.
Comment 13 Alexey Proskuryakov 2006-12-16 03:02:51 PST
Committed revision 18253.
Comment 14 Matt Lilek 2006-12-18 17:14:24 PST
*** Bug 10747 has been marked as a duplicate of this bug. ***