Bug 11632 - REGRESSION (r17770): Overflow areas' scrollbars don't work
Summary: REGRESSION (r17770): Overflow areas' scrollbars don't work
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Major
Assignee: Darin Adler
URL: data:text/html,%3Cdiv%20style=%22widt...
Keywords: InRadar, Regression
: 11612 11629 11687 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-11-17 08:44 PST by mitz
Modified: 2006-12-04 13:50 PST (History)
8 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2006-11-17 08:44:11 PST
Scrollbars on overflow areas (including list boxes and text areas) don't receive mouse events.
Comment 1 Matt Lilek 2006-11-17 08:54:57 PST
*** Bug 11629 has been marked as a duplicate of this bug. ***
Comment 2 mitz 2006-11-17 09:03:40 PST
Oops, I should have augmented the earlier bug report, but I didn't make the connection between "arrows" and scrollbars (I thought it was about the arrow keys). Sorry, Daniele.
Comment 3 Daniele Metilli 2006-11-17 09:11:27 PST
(In reply to comment #2)
> Oops, I should have augmented the earlier bug report, but I didn't make the
> connection between "arrows" and scrollbars (I thought it was about the arrow
> keys). Sorry, Daniele.
> 

No problem :)
Comment 4 Matt Lilek 2006-11-24 10:46:23 PST
*** Bug 11687 has been marked as a duplicate of this bug. ***
Comment 5 Chris Petersen 2006-11-29 10:55:49 PST
I have been running into this issue as well. I filed a crash that is related to dragging in a list box that started with r17770.

http://bugs.webkit.org/show_bug.cgi?id=11713
Comment 6 mitz 2006-11-30 08:47:52 PST
*** Bug 11612 has been marked as a duplicate of this bug. ***
Comment 7 Darin Adler 2006-12-04 13:40:30 PST
<rdar://problem/4858866> REGRESSION (r17770): Overflow areas' scrollbars don't work
Comment 8 Darin Adler 2006-12-04 13:41:43 PST
Committed revision 18001.