Bug 11612 - overflow:auto block the vertical scroller
Summary: overflow:auto block the vertical scroller
Status: RESOLVED DUPLICATE of bug 11632
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.yvon-thoraval.com/CSS/foot...
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-15 22:24 PST by Une Bévue
Modified: 2006-11-30 08:47 PST (History)
2 users (show)

See Also:


Attachments
Simple Testcase (3.42 KB, text/html)
2006-11-30 02:41 PST, Fabian Jakobs
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Une Bévue 2006-11-15 22:24:46 PST
on the page <a href="http://www.yvon-thoraval.com/CSS/footer_long.html">overflow:auto block the vertical scroller</a> this css is only effective on the div #content.

then, no way to scroll up and down the content of a page whose content is larger than the window height.

obviously this doesn't appear if the content of the page is smaller than the window height, a counter example being here :

<a href="http://www.yvon-thoraval.com/CSS/footer.html">ocounter-example</a>

no need of a vertical scroller at all.

best,

Yvon
Comment 1 Fabian Jakobs 2006-11-30 02:39:26 PST
I have encountered the same problem. However this does occur for overflow:scroll as Well. Further the horizontal scrollbar doesn't work either.

I would suggest to change the title to something like:

"overflow:auto and overflow:scroll block the vertical and horizontal scroller"
Comment 2 Fabian Jakobs 2006-11-30 02:41:31 PST
Created attachment 11677 [details]
Simple Testcase

attached testcase. Just try to use the scroolbars with WebKit nightly. It is not working.
Comment 3 mitz 2006-11-30 08:47:52 PST

*** This bug has been marked as a duplicate of 11632 ***