Bug 10747 - REGRESSION: Using two fingers on a trackpad to scroll inside a text area makes the whole page move
Summary: REGRESSION: Using two fingers on a trackpad to scroll inside a text area make...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL:
Keywords: InRadar, Regression
: 13024 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-09-06 02:08 PDT by Daniele Metilli
Modified: 2007-03-20 15:33 PDT (History)
5 users (show)

See Also:


Attachments
Test case (10.48 KB, text/html)
2006-09-06 02:09 PDT, Daniele Metilli
no flags Details
Test case (10.52 KB, text/html)
2006-09-08 00:39 PDT, Daniele Metilli
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniele Metilli 2006-09-06 02:08:09 PDT
If you try to use a scroll wheel inside a text area, you will see that the whole page moves together with it.

You can try this in the attached test case.

This happens in TOT (r16248), it doesn't happen in the latest stable version.
Comment 1 Daniele Metilli 2006-09-06 02:09:17 PDT
Created attachment 10412 [details]
Test case
Comment 2 jonathanjohnsson 2006-09-07 13:28:53 PDT
I can't see any difference in behaviour from latest release, neither in 16225 nor in 16259. Maybe the bug was introduced and fixed in between?
Comment 3 Daniele Metilli 2006-09-08 00:36:48 PDT
I was wrong, it only happens with the two-fingers scrolling on my MacBook trackpad.

Scrolling with a Mighty Mouse scroll wheel works correctly.

It is still a regression, trackpad scrolling works in the stable version of Safari.
Comment 4 Daniele Metilli 2006-09-08 00:39:15 PDT
Created attachment 10449 [details]
Test case
Comment 5 Rachael Worthington (cheers) 2006-10-23 11:04:37 PDT
I can reproduce this with a normal mouse in the latest nightly, by copying and pasting a block of text, pasting it into the Additional Comments text area a few times till there is a scroll wheel, and then scrolling over it.

whether focus is in the text area or not, the whole window scrolls, and not the text area.

reproed in the latest nightly as of Oct 23rd (r17205)
Comment 6 tim bates 2006-12-07 18:18:55 PST
I can confirm this bug.

In Daniele's regression, you can't scroll the text box with two-finger scrolling.

In addition, you can't scroll the text box using the mouse either. the thumb does not move when you click and drag on it.

I find this happening on many other  pages as well
Comment 7 Daniele Metilli 2006-12-18 13:06:28 PST
The status of this bug should be changed to NEW.
Comment 8 Matt Lilek 2006-12-18 17:14:24 PST
This was fixed in r18253.

*** This bug has been marked as a duplicate of 11313 ***
Comment 9 Daniele Metilli 2007-01-11 09:26:21 PST
I'm re-opening this bug since it still happens in the latest nightly (r17865).

Please note that it only happens using two fingers on a trackpad, not using a scroll wheel.
Comment 10 Daniele Metilli 2007-01-11 09:28:52 PST
Oops, I meant 18765, not 17865.
Comment 11 Daniele Metilli 2007-01-18 17:11:48 PST
My test case still displays the problem. The one from bug 11313 works correctly.

I think this is because the page from 11313 can't be scrolled (it contains only the textarea).

Conversely, my test case contains some text below the textarea, so it shows the bug.
Comment 12 Matt Lilek 2007-01-18 18:43:59 PST
I can't reproduce this with my trackpad (nor my scrollwheel mouse fwiw), but I'm also using iScroll and not an officially supported scrollie trackpad so...that may or may not be the issue.

Can anyone else with an official trackpad confirm this?
Comment 13 David Kilzer (:ddkilzer) 2007-01-20 16:28:22 PST
Confirmed using a locally-built debug build of WebKit r18997 with Safari 2.0.4 (419.3) on Mac OS X 10.4.8 (8N1037) on a MacBook Pro Core 2 Duo.  Note that you must have the "Use two fingers to scroll" option enabled in the Keyboard & Mouse preference pane for the trackpad.

Comment 14 Alexey Proskuryakov 2007-02-27 22:15:21 PST
Regression -> P1
Comment 15 Mark Rowe (bdash) 2007-03-07 06:45:02 PST
<rdar://problem/5045710>
Comment 16 Adele Peterson 2007-03-15 12:14:25 PDT
*** Bug 13024 has been marked as a duplicate of this bug. ***
Comment 17 Antti Koivisto 2007-03-18 17:33:53 PDT
Trackpad is generating wheel NSEvents which have both deltaX and deltaY set to 0. These events are ignored by WebCore and so get forwarded to the view. There they actually make the NSScrollView scroll. I wonder what is the logic there... Mouse wheel does not generate these (0,0) events so does not have the same scrolling problems.

Trivial solution of just blocking (0,0) events seems to degrade speed and general feel of trackpad scrolling.
Comment 18 Antti Koivisto 2007-03-18 17:34:43 PDT
weinig pointed to http://developer.apple.com/qa/qa2005/qa1453.html which might be relevant
Comment 19 Antti Koivisto 2007-03-20 15:33:15 PDT
r20349

Also filed bug 13134, "Implement smooth scroll events"