Bug 11133 - Regression (NativeListBox): Text paints on top of the list's scrollbar
Summary: Regression (NativeListBox): Text paints on top of the list's scrollbar
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://bugs.webkit.org/enter_bug.cgi
Keywords: Regression
: 11816 12076 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-10-03 09:58 PDT by mitz
Modified: 2007-01-07 04:04 PST (History)
3 users (show)

See Also:


Attachments
Fix option clipping and correct scrollbar widths (11.95 KB, patch)
2007-01-07 02:01 PST, mitz
mrowe: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2006-10-03 09:58:20 PDT
The longer options in the Component list box on the Enter Bug form (the URL) paint on top of the box's scroll bar (you need to scroll down a little to see them).
Comment 1 mitz 2006-10-03 13:54:47 PDT
Maybe clipping isn't really supposed to happen. Firefox (as well as shipping Safari) just make the list box wide enough to fit the longest option. So maybe that's the problem here.
Comment 2 Timothy Hatcher 2006-10-05 09:02:08 PDT
We would still need a clip if the listbox has an explicit width set in CSS.
Comment 3 mitz 2006-10-05 13:38:46 PDT

*** This bug has been marked as a duplicate of 11172 ***
Comment 4 mitz 2006-10-13 01:06:18 PDT
I'm reopening this bug so that bug 11172 would be about the layout issue, which is fixed now, and this would be about the clipping, which still needs to be addressed. To see an example of where you still need clipping, look at the CC: list for bug 11172.
Comment 5 Adele Peterson 2006-10-13 01:13:58 PDT
Hmm- I thought I'd seen this before, but now I don't see the text on top of the scrollbar in the component list box.  Mitz- are you still seeing it there?  Or is there another example?
Comment 6 mitz 2006-10-13 01:21:04 PDT
(In reply to comment #5)
> Hmm- I thought I'd seen this before, but now I don't see the text on top of the
> scrollbar in the component list box.  Mitz- are you still seeing it there?  Or
> is there another example?
> 

I'm seeing it in the CC list of bug 11172 (top right). Specifically, with the first email address in it. In shipping Safari it's clipped.
Comment 7 mitz 2006-10-13 01:22:55 PDT
Here's another example:

<select multiple style="width: 100px; font-size: 20px;">
<option>Lorem ipsum dolor sit amet</option>
</select>
Comment 8 Adele Peterson 2006-10-13 01:27:41 PDT
ha, i get it now :)
Comment 9 Mark Rowe (bdash) 2006-12-12 17:23:48 PST
*** Bug 11816 has been marked as a duplicate of this bug. ***
Comment 10 David Kilzer (:ddkilzer) 2006-12-12 20:41:04 PST
This is a regression from shipping Safari.

Comment 11 mitz 2007-01-02 11:53:05 PST
*** Bug 12076 has been marked as a duplicate of this bug. ***
Comment 12 mitz 2007-01-07 02:01:43 PST
Created attachment 12274 [details]
Fix option clipping and correct scrollbar widths
Comment 13 Mark Rowe (bdash) 2007-01-07 02:06:30 PST
Comment on attachment 12274 [details]
Fix option clipping and correct scrollbar widths

Nice, glad to see this dealt with!
Comment 14 Alexey Proskuryakov 2007-01-07 04:04:07 PST
Committed revision 18648.