Bug 108597 - [EFL][WK2] MiniBrowser segfaults on loading google.com
Summary: [EFL][WK2] MiniBrowser segfaults on loading google.com
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 108586 108606 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-01 01:34 PST by Gwang Yoon Hwang
Modified: 2013-02-01 08:59 PST (History)
11 users (show)

See Also:


Attachments
Patch (4.94 KB, patch)
2013-02-01 01:38 PST, Gwang Yoon Hwang
kling: review+
kling: commit-queue+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gwang Yoon Hwang 2013-02-01 01:34:08 PST
[EFL][WK2] MiniBrowser segfaults on loading google.com
Comment 1 Gwang Yoon Hwang 2013-02-01 01:38:50 PST
Created attachment 185977 [details]
Patch
Comment 2 Chris Dumez 2013-02-01 01:46:12 PST
We hit an assertion on debug builds:
ERROR: Thread name "com.apple.WebKit.ProcessLauncher" is longer than 31 characters and will be truncated by Visual Studio
/home/chris/Devel/WebKit/Source/WTF/wtf/Threading.cpp(78) : WTF::ThreadIdentifier WTF::createThread(WTF::ThreadFunction, void*, const char*)
HTML5 local storage is enabled for this view.
SHOULD NEVER BE REACHED
/home/chris/Devel/WebKit/Source/WebKit2/Platform/CoreIPC/unix/ConnectionUnix.cpp(227) : bool CoreIPC::Connection::processMessage()
1   0x7f95a5c91bb4 CoreIPC::Connection::processMessage()
2   0x7f95a5c92818 CoreIPC::Connection::readyReadHandler()
3   0x7f95a5a197da WTF::FunctionWrapper<void (CoreIPC::Connection::*)()>::operator()(CoreIPC::Connection*)
4   0x7f95a5a195b4 WTF::BoundFunctionImpl<WTF::FunctionWrapper<void (CoreIPC::Connection::*)()>, void (CoreIPC::Connection*)>::operator()()
5   0x7f95a5b583d0 WTF::Function<void ()>::operator()() const
6   0x7f95a5c8fb5c WorkQueue::performFileDescriptorWork()
7   0x7f95a5c8ff7e WorkQueue::workQueueThread(WorkQueue*)
8   0x7f95a234f2e1
9   0x7f95a2376e3a
10  0x7f959cd00e9a
11  0x7f95a4e6ccbd clone
LEAK: 1 WebPage
LEAK: 1 WebFrame
LEAK: 3 RenderObject
LEAK: 1 Page
LEAK: 1 Frame
LEAK: 1 CachedResource
LEAK: 1 SubresourceLoader
LEAK: 4 WebCoreNode
Segmentation fault (core dumped)
Comment 3 Gwang Yoon Hwang 2013-02-01 01:52:46 PST
(In reply to comment #2)

It is due to the omitted break statement;
This patch fixes that issue too.
Comment 4 Chris Dumez 2013-02-01 01:55:38 PST
The patches fixes the issue for me. Thanks.
Comment 5 Simon Hausmann 2013-02-01 02:08:00 PST
Committed r141562: <http://trac.webkit.org/changeset/141562>
Comment 6 Carlos Garcia Campos 2013-02-01 02:52:57 PST
*** Bug 108606 has been marked as a duplicate of this bug. ***
Comment 7 Viatcheslav Ostapenko 2013-02-01 08:59:10 PST
*** Bug 108586 has been marked as a duplicate of this bug. ***