Bug 108586 - [EFL][Qt][WK2] Regression(141528) Minibrowser asserts in debug build.
Summary: [EFL][Qt][WK2] Regression(141528) Minibrowser asserts in debug build.
Status: RESOLVED DUPLICATE of bug 108597
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Viatcheslav Ostapenko
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-31 23:21 PST by Viatcheslav Ostapenko
Modified: 2013-02-01 12:22 PST (History)
6 users (show)

See Also:


Attachments
Patch (1.48 KB, patch)
2013-01-31 23:25 PST, Viatcheslav Ostapenko
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Viatcheslav Ostapenko 2013-01-31 23:21:46 PST
SHOULD NEVER BE REACHED
/home/sl/work/webkit/Source/WebKit2/Platform/CoreIPC/unix/ConnectionUnix.cpp(228) : bool CoreIPC::Connection::processMessage()
1   0xb72e946e CoreIPC::Connection::processMessage()
2   0xb72e9f7b CoreIPC::Connection::readyReadHandler()
3   0xb7071ce8 WTF::FunctionWrapper<void (CoreIPC::Connection::*)()>::operator()(CoreIPC::Connection*)
4   0xb7071ac2 WTF::BoundFunctionImpl<WTF::FunctionWrapper<void (CoreIPC::Connection::*)()>, void (CoreIPC::Connection*)>::operator()()
5   0xb71b106a WTF::Function<void ()>::operator()() const
6   0xb72e73dd WorkQueue::performFileDescriptorWork()
7   0xb72e77ff WorkQueue::workQueueThread(WorkQueue*)
8   0xb3c65cba
9   0xb3c8d9ae
10  0xafcf6d4c
11  0xb65ecd3e clone

r141528 added ASSERT_NOT_REACHED to default case of switch, but didn't add break to the previous case.
Comment 1 Viatcheslav Ostapenko 2013-01-31 23:25:55 PST
Created attachment 185954 [details]
Patch
Comment 2 Viatcheslav Ostapenko 2013-02-01 08:59:10 PST

*** This bug has been marked as a duplicate of bug 108597 ***
Comment 3 Rafael Brandao 2013-02-01 12:21:28 PST
LGTM.

You should ask Anders to take a look.
Comment 4 Rafael Brandao 2013-02-01 12:22:23 PST
Sorry for the buzz, it's already solved.