Bug 108606 - [WK2][UNIX] REGRESSION(r141528): Crash in Connection::processMessage()
Summary: [WK2][UNIX] REGRESSION(r141528): Crash in Connection::processMessage()
Status: RESOLVED DUPLICATE of bug 108597
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk, Qt
Depends on:
Blocks:
 
Reported: 2013-02-01 02:36 PST by Carlos Garcia Campos
Modified: 2013-02-01 02:53 PST (History)
3 users (show)

See Also:


Attachments
Patch (1.52 KB, patch)
2013-02-01 02:39 PST, Carlos Garcia Campos
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2013-02-01 02:36:20 PST
In r141528 the if (attachmentCount) has been split, but in the second if, the attachmentCount might have changed.
Comment 1 Carlos Garcia Campos 2013-02-01 02:39:57 PST
Created attachment 185992 [details]
Patch
Comment 2 Carlos Garcia Campos 2013-02-01 02:52:57 PST
This was fixed in r141562 already :-)

*** This bug has been marked as a duplicate of bug 108597 ***