Bug 106552 - [EFL][jhbuild] Use tarballs for gstreamer instead of git
Summary: [EFL][jhbuild] Use tarballs for gstreamer instead of git
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit EFL (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Chris Dumez
URL:
Keywords:
: 106570 (view as bug list)
Depends on:
Blocks: 106178 106573
  Show dependency treegraph
 
Reported: 2013-01-10 04:33 PST by Chris Dumez
Modified: 2013-01-10 13:45 PST (History)
10 users (show)

See Also:


Attachments
Patch (3.66 KB, patch)
2013-01-10 04:53 PST, Chris Dumez
no flags Details | Formatted Diff | Diff
Patch (3.66 KB, patch)
2013-01-10 08:24 PST, Chris Dumez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Dumez 2013-01-10 04:33:34 PST
Due to networking problems on the build bots, using git in jhbuild should be avoided or jhbuild will sometimes fail like this:
http://build.webkit.org/builders/EFL%20Linux%2064-bit%20Debug%20WK2/builds/7876

Using tarballs is safer because they are cached and require no network operation if the checksum matches.
Comment 1 Chris Dumez 2013-01-10 04:53:01 PST
Created attachment 182115 [details]
Patch
Comment 2 Dominik Röttsches (drott) 2013-01-10 08:17:08 PST
*** Bug 106570 has been marked as a duplicate of this bug. ***
Comment 3 Raphael Kubo da Costa (:rakuco) 2013-01-10 08:21:06 PST
(In reply to comment #2)
> *** Bug 106570 has been marked as a duplicate of this bug. ***

My plan in that bug was to make GTK use tarballs as well and add autogen-sh="configure" to the entries to fix problems with automake 1.13 + autogen.sh.

Would you like to do that in this patch or should I do that myself elsewhere?
Comment 4 Chris Dumez 2013-01-10 08:24:21 PST
Created attachment 182146 [details]
Patch

Fix typo in Changelog.
Comment 5 Chris Dumez 2013-01-10 08:26:25 PST
(In reply to comment #3)
> (In reply to comment #2)
> > *** Bug 106570 has been marked as a duplicate of this bug. ***
> 
> My plan in that bug was to make GTK use tarballs as well and add autogen-sh="configure" to the entries to fix problems with automake 1.13 + autogen.sh.
> 
> Would you like to do that in this patch or should I do that myself elsewhere?

I think we can do this in separate patches. I do not want to mix different changes in one patch. This patch is really about using tarballs instead of GIT to work around our networking problems on the bots.
Comment 6 Laszlo Gombos 2013-01-10 13:29:45 PST
Comment on attachment 182146 [details]
Patch

ok. I agree that we should avoid using git.
Comment 7 WebKit Review Bot 2013-01-10 13:45:07 PST
Comment on attachment 182146 [details]
Patch

Clearing flags on attachment: 182146

Committed r139360: <http://trac.webkit.org/changeset/139360>
Comment 8 WebKit Review Bot 2013-01-10 13:45:12 PST
All reviewed patches have been landed.  Closing bug.