Bug 104779 - REGRESSION (r137286-r137296): unit test failure in WebKit2APITests/TestWebKitWebContext
Summary: REGRESSION (r137286-r137296): unit test failure in WebKit2APITests/TestWebKit...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk, Regression
: 112421 (view as bug list)
Depends on: 113282 113707
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-12 01:44 PST by Zan Dobersek
Modified: 2013-04-03 08:43 PDT (History)
6 users (show)

See Also:


Attachments
Patch (1.81 KB, patch)
2013-04-01 02:43 PDT, Manuel Rego Casasnovas
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Zan Dobersek 2012-12-12 01:44:23 PST
A regression was introduced between r137286 and r137296, with the following unit test failing:

TEST: ./Tools/gtk/../Scripts/../../WebKitBuild/Release/Programs/WebKit2APITests/TestWebKitWebContext... (pid=31822)

  /webkit2/WebKitWebContext/default-context:                           OK

  /webkit2/WebKitWebContext/get-plugins:                               OK

  /webkit2/WebKitWebContext/uri-scheme:                                **

ERROR:../../Source/WebKit2/UIProcess/API/gtk/tests/WebViewTest.cpp:206:void resourceGetDataCallback(GObject*, GAsyncResult*, gpointer): assertion failed: (data)

FAIL

The two related builds:
http://build.webkit.org/builders/GTK%20Linux%2064-bit%20Release/builds/32032
http://build.webkit.org/builders/GTK%20Linux%2064-bit%20Release/builds/32033

The commit range:
http://trac.webkit.org/log/?verbose=on&rev=137296&stop_rev=137286

I'll just do the common thing and for starters blame the libsoup bump in r137286.
http://trac.webkit.org/changeset/137286
Comment 1 Zan Dobersek 2012-12-12 03:15:07 PST
Skipped in r137434.
http://trac.webkit.org/changeset/137434
Comment 2 Zan Dobersek 2012-12-20 04:10:04 PST
Was treating this as a regression after r137198, but that patch has since been rolled out and the test is still failing.
http://trac.webkit.org/changeset/137198

Perhaps this is related to the recent MainResourceLoader modifications, for instance r137333 and similar patches.
http://trac.webkit.org/changeset/137333

Good thing I have time for a bisection!
Comment 3 Zan Dobersek 2013-02-27 07:47:09 PST
Tested this with r144170 and the failure still occurs.
Comment 4 Manuel Rego Casasnovas 2013-03-16 03:34:38 PDT
*** Bug 112421 has been marked as a duplicate of this bug. ***
Comment 5 Manuel Rego Casasnovas 2013-03-26 01:27:59 PDT
I've been taking a look to this issue, I don't have too much information but I'd like to share it here.

On one hand, the test works for me in the stable branch, however it's failing in trunk (and it was already failing when I reported the duplicated bug #112421).

On the other hand, it seems that the problem is that DocumentLoader::mainResourceData() is returning NULL. This means that dataReference in WebPage::getMainResourceDataOfFrame() is not properly initialized.
Comment 6 Carlos Garcia Campos 2013-03-31 03:26:34 PDT
It doesn't fail for me with a recent trunk (r146868)
Comment 7 Manuel Rego Casasnovas 2013-04-01 02:18:40 PDT
(In reply to comment #6)
> It doesn't fail for me with a recent trunk (r146868)

It's working for me too in r147306.
Comment 8 Carlos Garcia Campos 2013-04-01 02:34:12 PDT
Could someone unskip it and close this, please?
Comment 9 Manuel Rego Casasnovas 2013-04-01 02:43:40 PDT
Created attachment 195947 [details]
Patch
Comment 10 WebKit Review Bot 2013-04-01 03:44:53 PDT
Comment on attachment 195947 [details]
Patch

Clearing flags on attachment: 195947

Committed r147319: <http://trac.webkit.org/changeset/147319>
Comment 11 WebKit Review Bot 2013-04-01 03:44:57 PDT
All reviewed patches have been landed.  Closing bug.
Comment 12 WebKit Review Bot 2013-04-01 09:44:52 PDT
Re-opened since this is blocked by bug 113707
Comment 13 Zan Dobersek 2013-04-01 09:48:00 PDT
(In reply to comment #12)
> Re-opened since this is blocked by bug 113707

The test is still failing on the 64-bit release builder, so rolling the unskip patch out. The failure is still the same.
Comment 14 Carlos Garcia Campos 2013-04-03 01:56:54 PDT
(In reply to comment #13)
> (In reply to comment #12)
> > Re-opened since this is blocked by bug 113707
> 
> The test is still failing on the 64-bit release builder, so rolling the unskip patch out. The failure is still the same.

hmm, I managed to reproduce the issue in the 64 bit release bot. It seems the scheme handlers are registered correctly, but libsoup is not handling them. I've just built a new libsoup in the bot and it works, so this will be fixed when bug #113282 lands.
Comment 15 Zan Dobersek 2013-04-03 08:15:03 PDT
Comment on attachment 195947 [details]
Patch

Bug #113282 landed, perhaps just flipping the cq flag on this patch will do all the magic of landing, removing the need to reupload the same patch.
Comment 16 Carlos Garcia Campos 2013-04-03 08:17:58 PDT
Comment on attachment 195947 [details]
Patch

Wait a bit bots still don't build, and the patch has Reviewed by NOBODY
Comment 17 Zan Dobersek 2013-04-03 08:23:35 PDT
Ugh, right. Sorry for jumping forward with it.
Comment 18 Carlos Garcia Campos 2013-04-03 08:23:41 PDT
Comment on attachment 195947 [details]
Patch

Sorry, it seems the 64 bit release bot is building fine now.
Comment 19 WebKit Review Bot 2013-04-03 08:43:42 PDT
Comment on attachment 195947 [details]
Patch

Clearing flags on attachment: 195947

Committed r147559: <http://trac.webkit.org/changeset/147559>
Comment 20 WebKit Review Bot 2013-04-03 08:43:47 PDT
All reviewed patches have been landed.  Closing bug.