Bug 112421 - [GTK][WK2] REGRESSION: Unit test webkit2/WebKitWebContext/uri-scheme if failing
Summary: [GTK][WK2] REGRESSION: Unit test webkit2/WebKitWebContext/uri-scheme if failing
Status: RESOLVED DUPLICATE of bug 104779
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-15 02:37 PDT by Manuel Rego Casasnovas
Modified: 2013-03-16 03:34 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Rego Casasnovas 2013-03-15 02:37:30 PDT
The tests fails in trunk, but it is working properly in the stable branch:

ERROR:../../Source/WebKit2/UIProcess/API/gtk/tests/WebViewTest.cpp:206:void resourceGetDataCallback(GObject*, GAsyncResult*, gpointer): assertion failed: (data)

Backtrace:

#0  0x00007ffff49cd425 in raise () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007ffff49d0b8b in abort () from /lib/x86_64-linux-gnu/libc.so.6
#2  0x00007ffff7eeab07 in g_assertion_message (domain=domain@entry=0x0, file=file@entry=0x410130 "../../Source/WebKit2/UIProcess/API/gtk/tests/WebViewTest.cpp", line=line@entry=206, 
    func=func@entry=0x410300 <resourceGetDataCallback(_GObject*, _GAsyncResult*, void*)::__PRETTY_FUNCTION__> "void resourceGetDataCallback(GObject*, GAsyncResult*, gpointer)", message=<optimized out>)
    at gtestutils.c:1882
#3  0x00007ffff7eeb064 in g_assertion_message_expr (domain=0x0, file=0x410130 "../../Source/WebKit2/UIProcess/API/gtk/tests/WebViewTest.cpp", line=206, 
    func=0x410300 <resourceGetDataCallback(_GObject*, _GAsyncResult*, void*)::__PRETTY_FUNCTION__> "void resourceGetDataCallback(GObject*, GAsyncResult*, gpointer)", expr=<optimized out>) at gtestutils.c:1893
#4  0x000000000040d341 in resourceGetDataCallback(_GObject*, _GAsyncResult*, void*) ()
#5  0x00007ffff50cbd3e in g_simple_async_result_complete (simple=0x5a2200) at gsimpleasyncresult.c:777
#6  0x00007ffff5c9d5c2 in resourceDataCallback(OpaqueWKData const*, OpaqueWKError const*, void*) () from /home/mrego/work/WebKit/WebKitBuild/Release/.libs/libwebkit2gtk-3.0.so.0
#7  0x00007ffff5cfdf21 in WebKit::WebPageProxy::dataCallback(CoreIPC::DataReference const&, unsigned long) () from /home/mrego/work/WebKit/WebKitBuild/Release/.libs/libwebkit2gtk-3.0.so.0
#8  0x00007ffff5db84e7 in void CoreIPC::handleMessage<Messages::WebPageProxy::DataCallback, WebKit::WebPageProxy, void (WebKit::WebPageProxy::*)(CoreIPC::DataReference const&, unsigned long)>(CoreIPC::MessageDecoder&, WebKit::WebPageProxy*, void (WebKit::WebPageProxy::*)(CoreIPC::DataReference const&, unsigned long)) () from /home/mrego/work/WebKit/WebKitBuild/Release/.libs/libwebkit2gtk-3.0.so.0
#9  0x00007ffff5db43ed in WebKit::WebPageProxy::didReceiveMessage(CoreIPC::Connection*, CoreIPC::MessageDecoder&) () from /home/mrego/work/WebKit/WebKitBuild/Release/.libs/libwebkit2gtk-3.0.so.0
#10 0x00007ffff5c28f65 in CoreIPC::MessageReceiverMap::dispatchMessage(CoreIPC::Connection*, CoreIPC::MessageDecoder&) () from /home/mrego/work/WebKit/WebKitBuild/Release/.libs/libwebkit2gtk-3.0.so.0
#11 0x00007ffff5d17501 in WebKit::WebProcessProxy::didReceiveMessage(CoreIPC::Connection*, CoreIPC::MessageDecoder&) () from /home/mrego/work/WebKit/WebKitBuild/Release/.libs/libwebkit2gtk-3.0.so.0
#12 0x00007ffff5c23153 in CoreIPC::Connection::dispatchMessage(WTF::PassOwnPtr<CoreIPC::MessageDecoder>) () from /home/mrego/work/WebKit/WebKitBuild/Release/.libs/libwebkit2gtk-3.0.so.0
#13 0x00007ffff5c232c0 in CoreIPC::Connection::dispatchOneMessage() () from /home/mrego/work/WebKit/WebKitBuild/Release/.libs/libwebkit2gtk-3.0.so.0
#14 0x00007ffff6ce4dab in WebCore::RunLoop::performWork() () from /home/mrego/work/WebKit/WebKitBuild/Release/.libs/libwebkit2gtk-3.0.so.0
#15 0x00007ffff71db999 in WebCore::RunLoop::queueWork(WebCore::RunLoop*) () from /home/mrego/work/WebKit/WebKitBuild/Release/.libs/libwebkit2gtk-3.0.so.0
#16 0x00007ffff7ec8375 in g_main_dispatch (context=0x45ebc0) at gmain.c:2784
#17 g_main_context_dispatch (context=context@entry=0x45ebc0) at gmain.c:3288
#18 0x00007ffff7ec86b8 in g_main_context_iterate (context=0x45ebc0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3359
#19 0x00007ffff7ec8b22 in g_main_loop_run (loop=0x5429a0) at gmain.c:3553
#20 0x000000000040dd90 in WebViewTest::mainResourceData(unsigned long&) ()
#21 0x00000000004086ee in testWebContextURIScheme(URISchemeTest*, void const*) ()
#22 0x00007ffff7eeb22d in test_case_run (tc=0x533c10) at gtestutils.c:1684
#23 g_test_run_suite_internal (suite=suite@entry=0x534ca0, path=<optimized out>, path@entry=0x7ffff7f307cd "") at gtestutils.c:1737
#24 0x00007ffff7eeb3a6 in g_test_run_suite_internal (suite=suite@entry=0x534c80, path=<optimized out>, path@entry=0x7ffff7f307cd "") at gtestutils.c:1748
#25 0x00007ffff7eeb3a6 in g_test_run_suite_internal (suite=suite@entry=0x534d20, path=<optimized out>, path@entry=0x7ffff7f307cd "") at gtestutils.c:1748
#26 0x00007ffff7eeb70b in g_test_run_suite (suite=0x534d20) at gtestutils.c:1793
#27 0x000000000040d112 in main ()
Comment 1 Carlos Garcia Campos 2013-03-16 03:06:47 PDT
The test seems to work in the bots
Comment 2 Manuel Rego Casasnovas 2013-03-16 03:34:38 PDT

*** This bug has been marked as a duplicate of bug 104779 ***