Bug 93615

Summary: [V8] Introduce V8DOMConfiguration class and make batchConfigureXXX() methods static
Product: WebKit Reporter: Kentaro Hara <haraken>
Component: WebCore JavaScriptAssignee: Kentaro Hara <haraken>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, eric.carlson, feature-media-reviews, gyuyoung.kim, japhet, rakuco, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 93095    
Attachments:
Description Flags
Patch
none
Patch
none
patch for landing none

Description Kentaro Hara 2012-08-09 05:54:42 PDT
Per the discussion in bug 93239,

(1) Rename V8ConfigureDOMAttributesAndMethods to V8DOMConfiguration.
(2) Introduce V8DOMConfiguration class and make batchConfigureXXX() methods static.
Comment 1 Kentaro Hara 2012-08-09 19:51:10 PDT
Created attachment 157617 [details]
Patch
Comment 2 Kentaro Hara 2012-08-09 20:20:33 PDT
Created attachment 157622 [details]
Patch
Comment 3 Adam Barth 2012-08-10 00:56:39 PDT
Comment on attachment 157622 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=157622&action=review

> Source/WebCore/bindings/v8/V8DOMConfiguration.cpp:37
> +                                                  v8::Handle<v8::ObjectTemplate> proto, 

I would clean up all these names too.  e.g., proto -> prototype

> Source/WebCore/bindings/v8/V8DOMConfiguration.cpp:67
> +v8::Local<v8::Signature> V8DOMConfiguration::configureTemplate(v8::Persistent<v8::FunctionTemplate> desc,

desc -> functionDescriptor

> Source/WebCore/bindings/v8/V8DOMConfiguration.cpp:68
> +                                                               const char *interfaceName,

"const char *" -> "const char*"

> Source/WebCore/bindings/v8/V8DOMConfiguration.cpp:70
> +                                                               int fieldCount,

int -> size_t ?

> Source/WebCore/bindings/v8/V8DOMConfiguration.h:53
> +        bool onProto;

onProto -> onPrototype

> Source/WebCore/bindings/v8/V8DOMConfiguration.h:63
> +                                          v8::Handle<ObjectOrTemplate> proto,

proto -> prototype

> Source/WebCore/bindings/v8/V8DOMConfiguration.h:65
> +        {

Bad indent
Comment 4 Kentaro Hara 2012-08-10 06:24:24 PDT
Created attachment 157726 [details]
patch for landing
Comment 5 WebKit Review Bot 2012-08-10 10:03:31 PDT
Comment on attachment 157726 [details]
patch for landing

Clearing flags on attachment: 157726

Committed r125295: <http://trac.webkit.org/changeset/125295>