Bug 231505

Summary: Error the encoder in case we cannot create a RemoteVideoSample
Product: WebKit Reporter: youenn fablet <youennf>
Component: WebRTCAssignee: youenn fablet <youennf>
Status: RESOLVED FIXED    
Severity: Normal CC: arungane, avasilko, csantos, daginge, darius.chris.k, engel.css, eric.amram, eric.carlson, kuznetsov.trueconf, makarand, ppramod, rychouwei, shpuluga, simmkyu, tomasz.malik, webkit-bug-importer, youennf
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch for landing none

Description youenn fablet 2021-10-11 02:29:05 PDT
Error the encoder in case we cannot create a RemoteVideoSample
Comment 1 youenn fablet 2021-10-11 02:29:16 PDT
<rdar://83975229>
Comment 2 youenn fablet 2021-10-11 02:33:05 PDT
Created attachment 440767 [details]
Patch
Comment 3 Eric Carlson 2021-10-11 08:57:27 PDT
Comment on attachment 440767 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=440767&action=review

> Source/WebKit/WebProcess/GPU/webrtc/LibWebRTCCodecs.cpp:451
> +        if (!sample)
> +            return WEBRTC_VIDEO_CODEC_ERROR;

It might be worth logging this error too.
Comment 4 youenn fablet 2021-10-12 01:35:18 PDT
Created attachment 440908 [details]
Patch for landing
Comment 5 EWS 2021-10-12 02:45:24 PDT
Committed r283975 (242821@main): <https://commits.webkit.org/242821@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 440908 [details].
Comment 6 Alexey Proskuryakov 2021-10-22 10:42:08 PDT
*** Bug 232006 has been marked as a duplicate of this bug. ***
Comment 7 Sam Sneddon [:gsnedders] 2021-10-27 22:06:28 PDT
*** Bug 232381 has been marked as a duplicate of this bug. ***
Comment 8 Sam Sneddon [:gsnedders] 2021-10-27 22:06:49 PDT
*** Bug 232416 has been marked as a duplicate of this bug. ***
Comment 9 youenn fablet 2021-10-29 05:40:39 PDT
*** Bug 232445 has been marked as a duplicate of this bug. ***
Comment 10 Sam Sneddon [:gsnedders] 2021-10-29 13:31:33 PDT
*** Bug 232490 has been marked as a duplicate of this bug. ***
Comment 11 ARUN GANESHAN 2021-10-29 17:49:28 PDT
HI team whats the update about this issues . What release will it be merged ?
Comment 12 Eric 2021-10-29 18:48:33 PDT
OMG.
How do you do QA at Apple? 
In times of Covid, you've just ruined WebRTC H264 on Safari?
And it went all the way to iOS 15.1 "stable"?

Now we have to tell ALL our clients NOT to use Apple products! Well done.
Comment 13 P Pramod 2021-10-31 01:22:34 PDT
It would help to get an update on the plan to address this issue?
Comment 14 daginge 2021-11-02 00:02:34 PDT
There was an update here: https://bugs.webkit.org/show_bug.cgi?id=232006#c9

I can confirm this is fixed in iOS 15.2 Public Beta.
Comment 15 rychouwei 2021-11-07 19:00:32 PST
two workaround:

1. Add this description to offer&answer sdp: "urn:3gpp:video-orientation", it will not cause page crash.
2. Use canvas.captureStream to capture a new video track from getUserMedia. Then, publish canvas track will not cause page crash.
Comment 16 Shanker Pulugam 2021-11-11 00:04:14 PST
Hi Webkit team,

Tried second workaround, used canvas captureStream from getUserMedia and publish canvas track but still crashes.
Can you please provide a working sample or any other way to fix the issue.
Comment 17 rychouwei 2021-11-11 00:22:00 PST
I'm not form webkit team.

The second workround works for our product.

You can try this sample to make a call on iOS 15.1: https://sdk-web-1252463788.cos.ap-hongkong.myqcloud.com/trtc/webrtc/test/rychou-test/addTransceiver/subscribe/index.html

This sample use canvas.captureStream and H.264 codec.

BTW, there is anothor workaround: use VP8 codec, do not use H.264
Comment 18 Alexey Proskuryakov 2021-11-12 16:13:54 PST
*** Bug 233038 has been marked as a duplicate of this bug. ***