Bug 233038 - Safari crashes on iOS after adding video track to RTCPeerConnection
Summary: Safari crashes on iOS after adding video track to RTCPeerConnection
Status: RESOLVED DUPLICATE of bug 231505
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebRTC (show other bugs)
Version: Safari 15
Hardware: iPhone / iPad iOS 15
: P2 Major
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-12 05:12 PST by kuznetsov.trueconf
Modified: 2021-11-12 16:13 PST (History)
1 user (show)

See Also:


Attachments
crash log (28.00 KB, text/plain)
2021-11-12 05:12 PST, kuznetsov.trueconf
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description kuznetsov.trueconf 2021-11-12 05:12:20 PST
Created attachment 444059 [details]
crash log

iOS: 15.1
Safari User Agent:  Mozilla/5.0 (iPhone; CPU iPhone OS 15_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.1 Mobile/15E148 Safari/604.1


1. Create new RTCPeerConnection
2. Connect to another peer
3. Сapture video from camera
4. Call addTrack on RTCPeerConnection and add video track
5. Safari crashes in WebCore::RemoteVideoSample::encode<IPC::Encoder>

Crash log in attachment.

Safari NOT crashes if munge SDP and remove H264 payload, or disable "WebRTC Platfrom Codecs in GPU Proccess" in extended Safari settings.
Comment 1 Alexey Proskuryakov 2021-11-12 16:13:54 PST
The crash log matches one for bug 231505.

*** This bug has been marked as a duplicate of bug 231505 ***