Bug 232445 - safari crashes when VideoTrack is disabled while in webrtc call
Summary: safari crashes when VideoTrack is disabled while in webrtc call
Status: RESOLVED DUPLICATE of bug 231505
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebRTC (show other bugs)
Version: Safari 15
Hardware: All All
: P2 Blocker
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-28 11:44 PDT by makarand
Modified: 2021-10-29 05:40 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description makarand 2021-10-28 11:44:18 PDT
On Safari 15.1 running on MacOS Monterey

1) Navigate to https://webrtc.github.io/samples/src/content/peerconnection/change-codecs/
2) Click Start (this acquire user media)
3) Click Call (this establishes webrtc call)
4) Using developer console disable Local Video track using:

localStream.getVideoTracks()[0].enabled = false

5) Notice that Safari crashes and reloads the page.



Note: this happens only when using default (H264 codec) if codec preferences was changed to VP8, crash does not happen.
Comment 1 daginge 2021-10-29 05:28:31 PDT
Duplicate of https://bugs.webkit.org/show_bug.cgi?id=232006. Fix is on the way, but didn't make it to 15.1 in time. Expected fix is 15.2, but it's anyone's guess. 

https://twitter.com/othermaciej/status/1452726880637906945?s=20
Comment 2 youenn fablet 2021-10-29 05:40:39 PDT
I would indeed look at upcoming iOS 15.2 betas.

*** This bug has been marked as a duplicate of bug 231505 ***