Bug 203609

Summary: Flaky Test: imported/w3c/web-platform-tests/html/semantics/forms/form-submission-0/form-double-submit-3.html
Product: WebKit Reporter: WebKit Commit Bot <commit-queue>
Component: Tools / TestsAssignee: WebKit Commit Bot <commit-queue>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: cdumez, webkit-bot-watchers-bugzilla
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=203499
https://bugs.webkit.org/show_bug.cgi?id=204800
Bug Depends on:    
Bug Blocks: 50856    
Attachments:
Description Flags
Archive of layout-test-results from webkit-cq-01
none
Archive of layout-test-results from webkit-cq-01
none
Archive of layout-test-results from webkit-cq-01 none

Description WebKit Commit Bot 2019-10-30 07:14:15 PDT
This is an automatically generated bug from the commit-queue.
imported/w3c/web-platform-tests/html/semantics/forms/form-submission-0/form-double-submit-3.html has been flaky on the commit-queue.

imported/w3c/web-platform-tests/html/semantics/forms/form-submission-0/form-double-submit-3.html was authored by cdumez@apple.com.
https://trac.webkit.org/browser/trunk/LayoutTests/imported/w3c/web-platform-tests/html/semantics/forms/form-submission-0/form-double-submit-3.html

The commit-queue just saw imported/w3c/web-platform-tests/html/semantics/forms/form-submission-0/form-double-submit-3.html flake (text diff) while processing attachment 382300 [details] on bug 201422.
Bot: webkit-cq-01  Port: <class 'webkitpy.common.config.ports.MacPort'>  Platform: Mac OS X 10.13.6

The bots will update this with information from each new failure.

If you believe this bug to be fixed or invalid, feel free to close.  The bots will re-open if the flake re-occurs.

If you would like to track this test fix with another bug, please close this bug as a duplicate.  The bots will follow the duplicate chain when making future comments.
Comment 1 WebKit Commit Bot 2019-10-30 07:14:16 PDT
Created attachment 382307 [details]
Archive of layout-test-results from webkit-cq-01
Comment 2 Alexey Proskuryakov 2019-10-30 22:59:58 PDT
This test was super flaky since it was added two days ago in r251677. It should at least be marked as such.

@@ -4,5 +4,5 @@
 
 submit
 
-FAIL <button> should have the same double-submit protection as <input type=submit> assert_unreached: Frame1 should not get navigated by this test. Reached unreachable code
+PASS <button> should have the same double-submit protection as <input type=submit>
Comment 3 WebKit Commit Bot 2019-11-08 19:02:09 PST
The commit-queue just saw imported/w3c/web-platform-tests/html/semantics/forms/form-submission-0/form-double-submit-3.html flake (text diff) while processing attachment 383161 [details] on bug 204019.
Bot: webkit-cq-01  Port: <class 'webkitpy.common.config.ports.MacPort'>  Platform: Mac OS X 10.13.6
Comment 4 WebKit Commit Bot 2019-11-08 19:02:10 PST
Created attachment 383194 [details]
Archive of layout-test-results from webkit-cq-01
Comment 5 WebKit Commit Bot 2019-11-20 14:16:52 PST
The commit-queue just saw imported/w3c/web-platform-tests/html/semantics/forms/form-submission-0/form-double-submit-3.html flake (text diff) while processing attachment 383330 [details] on bug 199060.
Bot: webkit-cq-01  Port: <class 'webkitpy.common.config.ports.MacPort'>  Platform: Mac OS X 10.13.6
Comment 6 WebKit Commit Bot 2019-11-20 14:16:53 PST
Created attachment 383984 [details]
Archive of layout-test-results from webkit-cq-01
Comment 7 Alexey Proskuryakov 2019-12-16 14:05:59 PST

*** This bug has been marked as a duplicate of bug 205164 ***