Bug 203140

Summary: Flaky Test: fast/events/resize-subframe-in-rendering-update.html
Product: WebKit Reporter: WebKit Commit Bot <commit-queue>
Component: Tools / TestsAssignee: WebKit Commit Bot <commit-queue>
Status: RESOLVED INVALID    
Severity: Normal CC: ap, koivisto, rniwa, simon.fraser, webkit-bug-importer, wenson_hsieh, zalan
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 203384    
Bug Blocks: 50856, 202964    
Attachments:
Description Flags
Archive of layout-test-results from webkit-cq-01
none
Archive of layout-test-results from webkit-cq-03
none
Fixes the test
simon.fraser: review+
Fix the test none

Description WebKit Commit Bot 2019-10-17 22:21:14 PDT
This is an automatically generated bug from the commit-queue.
fast/events/resize-subframe-in-rendering-update.html has been flaky on the commit-queue.

fast/events/resize-subframe-in-rendering-update.html was authored by rniwa@webkit.org.
https://trac.webkit.org/browser/trunk/LayoutTests/fast/events/resize-subframe-in-rendering-update.html

The commit-queue just saw fast/events/resize-subframe-in-rendering-update.html flake (text diff) while processing attachment 381247 [details] on bug 203021.
Bot: webkit-cq-01  Port: <class 'webkitpy.common.config.ports.MacPort'>  Platform: Mac OS X 10.13.6

The bots will update this with information from each new failure.

If you believe this bug to be fixed or invalid, feel free to close.  The bots will re-open if the flake re-occurs.

If you would like to track this test fix with another bug, please close this bug as a duplicate.  The bots will follow the duplicate chain when making future comments.
Comment 1 WebKit Commit Bot 2019-10-17 22:21:16 PDT
Created attachment 381269 [details]
Archive of layout-test-results from webkit-cq-01
Comment 2 WebKit Commit Bot 2019-10-18 11:07:57 PDT
The commit-queue just saw fast/events/resize-subframe-in-rendering-update.html flake (text diff) while processing attachment 381307 [details] on bug 203153.
Bot: webkit-cq-03  Port: <class 'webkitpy.common.config.ports.MacPort'>  Platform: Mac OS X 10.13.6
Comment 3 WebKit Commit Bot 2019-10-18 11:07:58 PDT
Created attachment 381316 [details]
Archive of layout-test-results from webkit-cq-03
Comment 4 Ryosuke Niwa 2019-10-18 12:22:53 PDT
Created attachment 381322 [details]
Fixes the test
Comment 5 Ryosuke Niwa 2019-10-18 12:43:36 PDT
Thanks for the review!
Comment 6 Ryosuke Niwa 2019-10-18 12:44:24 PDT
Committed r251294: <https://trac.webkit.org/changeset/251294>
Comment 7 Radar WebKit Bug Importer 2019-10-18 12:45:16 PDT
<rdar://problem/56415948>
Comment 8 Alexey Proskuryakov 2019-10-19 12:06:30 PDT
This substantially improved test stability, but it's still failing fairly frequently.

https://build.webkit.org/results/Apple%20High%20Sierra%20Debug%20WK1%20(Tests)/r251317%20(11394)/fast/events/resize-subframe-in-rendering-update-pretty-diff.html
Comment 9 Ryosuke Niwa 2019-10-19 14:26:16 PDT
(In reply to Alexey Proskuryakov from comment #8)
> This substantially improved test stability, but it's still failing fairly
> frequently.
> 
> https://build.webkit.org/results/
> Apple%20High%20Sierra%20Debug%20WK1%20(Tests)/r251317%20(11394)/fast/events/
> resize-subframe-in-rendering-update-pretty-diff.html

Hm... I did --iterations 100 to make sure it doesn't flake but I guess that was just on my machine.
Comment 10 Ryosuke Niwa 2019-10-19 15:16:08 PDT
Alright, the following command can reproduce the flakiness even on macOS Mojave:
./Tools/Scripts/run-webkit-tests --debug LayoutTests/fast/events/resize-* --iterations 100 --no-show-results --exit-after-n-failures=1 -1

I think the fundamental problem is that there is no way to order requestAnimationFrame and setTimeout deterministically right now. We need to remove the assertion inside setTimeout for now.
Comment 11 Ryosuke Niwa 2019-10-19 15:19:20 PDT
Created attachment 381376 [details]
Fix the test
Comment 12 WebKit Commit Bot 2019-10-19 16:50:39 PDT
Comment on attachment 381376 [details]
Fix the test

Clearing flags on attachment: 381376

Committed r251328: <https://trac.webkit.org/changeset/251328>
Comment 13 WebKit Commit Bot 2019-10-24 15:37:24 PDT
Re-opened since this is blocked by bug 203384