Bug 167977

Summary: Don't re-export WKUtilities.h from WebKit
Product: WebKit Reporter: Aakash Jain <aakash_jain>
Component: WebCore Misc.Assignee: Aakash Jain <aakash_jain>
Status: RESOLVED FIXED    
Severity: Normal CC: aakash_jain, ap, commit-queue, juergen
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=167996
https://bugs.webkit.org/show_bug.cgi?id=167998
https://bugs.webkit.org/show_bug.cgi?id=168020
Attachments:
Description Flags
Proposed patch
none
Updated patch none

Description Aakash Jain 2017-02-07 18:51:04 PST
WKUtilities.h contains several methods which are used only in WebCore (and need not be exported). However WKUtilities.h is a private header (not project header). We should move all these methods to a separate header file which would be project header.
Comment 1 Aakash Jain 2017-02-07 19:10:23 PST
Created attachment 300877 [details]
Proposed patch
Comment 2 WebKit Commit Bot 2017-02-07 19:14:08 PST
Attachment 300877 [details] did not pass style-queue:


ERROR: Source/WebCore/platform/ios/wak/WKUtilitiesPrivate.h:26:  Use #pragma once instead of #ifndef for header guard.  [build/header_guard] [5]
ERROR: Source/WebCore/platform/ios/wak/WKUtilitiesPrivate.h:42:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/platform/ios/wak/WKUtilitiesPrivate.h:42:  The parameter name "info" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/platform/ios/wak/WKUtilitiesPrivate.h:43:  The parameter name "object" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/platform/ios/wak/WKUtilitiesPrivate.h:44:  The parameter name "object" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/platform/ios/wak/WKUtilitiesPrivate.h:46:  The parameter name "allocator" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/platform/ios/wak/WKUtilitiesPrivate.h:47:  The parameter name "allocator" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/platform/ios/wak/WKUtilitiesPrivate.h:52:  The parameter name "array" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/platform/ios/wak/WKUtilitiesPrivate.h:54:  The parameter name "object" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 9 in 6 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Alexey Proskuryakov 2017-02-07 20:13:50 PST
Comment on attachment 300877 [details]
Proposed patch

View in context: https://bugs.webkit.org/attachment.cgi?id=300877&action=review

> Source/WebCore/ChangeLog:8
> +        * WebCore.xcodeproj/project.pbxproj: Added WKUtilitiesPrivate.h

The correct name for the new file is WKUtilitiesInternal.h. However, it's still not clear to me if anything from this header is needed as SPI.
Comment 4 Alexey Proskuryakov 2017-02-08 11:35:46 PST
Aakash and I looked into this. We just don't need to migrate this header in WebKit at all, as it's only used in WebKit via WKView.h, which is not migrated.
Comment 5 Aakash Jain 2017-02-08 13:28:39 PST
Created attachment 300952 [details]
Updated patch
Comment 6 WebKit Commit Bot 2017-02-08 14:06:11 PST
Comment on attachment 300952 [details]
Updated patch

Clearing flags on attachment: 300952

Committed r211901: <http://trac.webkit.org/changeset/211901>
Comment 7 WebKit Commit Bot 2017-02-08 14:06:14 PST
All reviewed patches have been landed.  Closing bug.