Bug 14254

Summary: Inspector node highlight applied to all tabs on OS X
Product: WebKit Reporter: Matt Lilek (pewtermoose) <mlilek@apple.com>
Component: Web Inspector (Deprecated)Assignee: Nobody <webkit-unassigned@lists.webkit.org>
Status: RESOLVED WORKSFORME    
Severity: Major CC: ain@flashbit.net, aroben@webkit.org, bburg@apple.com, cmf83@cornell.edu, dylanryan@mac.com, ian@panic.com, matt.sephton@gmail.com, niels.leenheer@gmail.com, rachael@omnigroup.com, rik@webkit.org
Priority: P2 Keywords: InRadar, PlatformOnly
Version: 528+ (Nightly build)   
Hardware: Macintosh   
OS: Mac OS X 10.5   
Bug Depends on:    
Bug Blocks: 14328, 17777    
Attachments:
Description Flags
Patch + ChangeLog to fix the issue on Windows none

Description From 2007-06-20 19:45:40 PST
When a node is highlighted in the new web inspector, the highlight is applied to all tabs in that window.
------- Comment #1 From 2007-06-21 09:36:02 PST -------
*** Bug 14277 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2007-10-27 08:02:50 PST -------
*** Bug 15723 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2007-12-20 16:31:34 PST -------
*** Bug 16405 has been marked as a duplicate of this bug. ***
------- Comment #4 From 2007-12-20 16:31:57 PST -------
Bug 16405 has more details on the badness this can cause.
------- Comment #5 From 2008-01-28 16:09:08 PST -------
<rdar://problem/5322306>
------- Comment #6 From 2008-03-01 16:40:20 PST -------
*** Bug 17630 has been marked as a duplicate of this bug. ***
------- Comment #7 From 2008-03-09 11:43:16 PST -------
Created an attachment (id=19617) [details]
Patch + ChangeLog to fix the issue on Windows
------- Comment #8 From 2008-03-09 15:46:19 PST -------
(From update of attachment 19617 [details])
r=me
------- Comment #9 From 2008-03-09 15:49:12 PST -------
(From update of attachment 19617 [details])
r=me
------- Comment #10 From 2008-03-09 16:02:19 PST -------
(From update of attachment 19617 [details])
Landed as r30910
------- Comment #11 From 2008-03-11 10:17:38 PST -------
(In reply to comment #10)
> (From update of attachment 19617 [details] [edit])
> Landed as r30910
> 

r30910 was for Windows - this still affects OS X. Updating it to reflect this.
------- Comment #12 From 2008-04-18 07:43:21 PST -------
This bug is really annoying for web developers.

If you're working on a bug and switching to any webpage to look a documentation, you have to quit the inspector every time.
------- Comment #13 From 2008-10-15 17:06:13 PST -------
Since last changes in behaviour (timeout for highlighting), this bug seems irrelevant now.
------- Comment #14 From 2008-10-15 17:55:06 PST -------
(In reply to comment #13)
> Since last changes in behaviour (timeout for highlighting), this bug seems
> irrelevant now.
> 

It isn't actually fixed, though. It is certainly well hidden, but the issue still remains.

New steps to reproduce:
1) Open 2 tabs in a WebKit window.
2) Inspect element in one of them, and mouse-over a node to highlight it
3) Right-click/control-click  the node you are mousing over, displaying a context menu
4) Select "Copy" (or any other option in the list) from this context menu
5) Click the WebKit window to bring it to the front
6) Change tabs
Highlight still present.

So, hidden? Yes. Fixed? No. It is fine as is since it is much less annoying, but since the problem is still there it might crop up later if the behavior ever changes again, or in any other places that the timer can be circumvented. 
------- Comment #15 From 2009-10-29 19:48:28 PST -------
*** Bug 26796 has been marked as a duplicate of this bug. ***
------- Comment #16 From 2014-01-12 10:51:00 PST -------
Can't reproduce this. I think the highlights use a different implementation now (InspectorOverlay) which is specific to the Page, not the viewport.