Bug 14328 - Assertion failure resizing window with docked inspector in background tab
Summary: Assertion failure resizing window with docked inspector in background tab
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
: 15349 (view as bug list)
Depends on: 14254
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-22 20:44 PDT by Matt Lilek
Modified: 2008-07-28 15:42 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Lilek 2007-06-22 20:44:59 PDT
ASSERTION FAILED: [_targetView window]
(Users/matt/Code/WebKit/WebKit/WebInspector/WebNodeHighlight.m:251 -[WebNodeHighlight(FileInternal) _repositionHighlightWindow])

1. Open Safari and load a site
2. Open the Inspector and dock it to the window
3. Open a new tab
4. Resize the window
5. Assert -> *BOOM*
Comment 1 Timothy Hatcher 2007-06-22 20:47:42 PDT
This will be fixed once bug 14254 is fixed.
Comment 2 Matt Lilek 2007-10-02 16:08:54 PDT
*** Bug 15349 has been marked as a duplicate of this bug. ***
Comment 3 Eric Seidel (no email) 2007-10-17 11:34:10 PDT
You also hit this assert if you have the inspector open and just open a new tab (if it's your first new tab and you have the tab bar hidden).
Comment 4 Adam Roben (:aroben) 2008-01-29 11:16:20 PST
<rdar://problem/5712940>
Comment 5 Kevin McCullough 2008-07-28 15:42:09 PDT
A lot of work has been done in this area and I can no loner reproduce.  can you please verify if this is fixed.