Bug 120045

Summary: [CSS Grid Layout] Add support for named grid areas
Product: WebKit Reporter: Ryosuke Niwa <rniwa>
Component: Layout and RenderingAssignee: Sergio Villar Senin <svillar>
Status: RESOLVED FIXED    
Severity: Normal CC: allan.jensen, bdakin, buildbot, commit-queue, darin, dino, eflews.bot, esprehn+autocc, glenn, gtk-ews, gyuyoung.kim, hyatt, kling, koivisto, kondapallykalyan, macpherson, menard, mihnea, rego+ews, rniwa, simon.fraser, svillar, syoichi, thorton, xan.lopez
Priority: P2 Keywords: BlinkMergeCandidate
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 103313    
Bug Blocks: 60731    
Attachments:
Description Flags
Patch
none
Patch
none
Patch kling: review+

Description Ryosuke Niwa 2013-08-19 17:52:22 PDT
Consider merging https://chromium.googlesource.com/chromium/blink/+/9b90c91c3b6f61947ecacf1ffd33aea89e834b8c

This is the final change in adding support for named grid areas:
extending the resolution code to handle named grid areas.

The patch is trivial as it builds on a lot of the
existing grid handling code.
Comment 1 Sergio Villar Senin 2013-10-08 01:15:44 PDT
(In reply to comment #0)
> Consider merging https://chromium.googlesource.com/chromium/blink/+/9b90c91c3b6f61947ecacf1ffd33aea89e834b8c
> 
> This is the final change in adding support for named grid areas:
> extending the resolution code to handle named grid areas.
> 
> The patch is trivial as it builds on a lot of the
> existing grid handling code.

The patch is indeed pretty simple but it requires the named grid area support which is not there yet
Comment 2 Sergio Villar Senin 2013-10-08 01:17:23 PDT
We should merge first https://chromiumcodereview.appspot.com/22215002

    Allow grid positions to be named grid areas
    
    This change extends our handling of grid position to allow for
    named grid areas. This required to split the shorthands parsing
    between grid-{row|column} and grid-area as the rules for expanding
    are slightly different.  The patch reuses a lot of the existing logic
    to marshall the values into RenderStyle.
    
    One big difference after this change is that:
    
    grid-row: foobar / none;
    
    used to be rejected at parsing but is now allowed.
Comment 4 Sergio Villar Senin 2013-10-24 04:18:39 PDT
Created attachment 215052 [details]
Patch
Comment 5 Sergio Villar Senin 2013-10-29 00:46:54 PDT
Created attachment 215369 [details]
Patch
Comment 6 EFL EWS Bot 2013-10-29 01:01:04 PDT
Comment on attachment 215369 [details]
Patch

Attachment 215369 [details] did not pass efl-ews (efl):
Output: http://webkit-queues.appspot.com/results/17118013
Comment 7 EFL EWS Bot 2013-10-29 01:11:16 PDT
Comment on attachment 215369 [details]
Patch

Attachment 215369 [details] did not pass efl-wk2-ews (efl-wk2):
Output: http://webkit-queues.appspot.com/results/17138014
Comment 8 Build Bot 2013-10-29 01:20:18 PDT
Comment on attachment 215369 [details]
Patch

Attachment 215369 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.appspot.com/results/17098012
Comment 9 Build Bot 2013-10-29 01:30:39 PDT
Comment on attachment 215369 [details]
Patch

Attachment 215369 [details] did not pass win-ews (win):
Output: http://webkit-queues.appspot.com/results/17118017
Comment 10 Build Bot 2013-10-29 01:35:16 PDT
Comment on attachment 215369 [details]
Patch

Attachment 215369 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.appspot.com/results/17118016
Comment 11 kov's GTK+ EWS bot 2013-10-29 01:41:37 PDT
Comment on attachment 215369 [details]
Patch

Attachment 215369 [details] did not pass gtk-ews (gtk):
Output: http://webkit-queues.appspot.com/results/17038021
Comment 12 Sergio Villar Senin 2013-10-29 02:04:27 PDT
Created attachment 215372 [details]
Patch

Rebased against latest changes
Comment 13 Sergio Villar Senin 2013-11-06 07:52:20 PST
Committed r158744: <http://trac.webkit.org/changeset/158744>
Comment 14 Sergio Villar Senin 2013-11-06 08:58:35 PST
*** Bug 120044 has been marked as a duplicate of this bug. ***