Bug 120044 - [CSS Grid Layout] Unknown grid area should compute to 'auto'
Summary: [CSS Grid Layout] Unknown grid area should compute to 'auto'
Status: RESOLVED DUPLICATE of bug 120045
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: BlinkMergeCandidate
Depends on: 103313 103334
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 17:51 PDT by Ryosuke Niwa
Modified: 2013-11-06 08:58 PST (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryosuke Niwa 2013-08-19 17:51:51 PDT
Consider merging https://chromium.googlesource.com/chromium/blink/+/f5c42430625856f4f0a711363fb5b66821314157

Per the specification, if the grid area specified for any <grid-line>
doesn't exist, it should compute to 'auto'. The original parsing
implementation allowed any <grid-line>, which is non-compliant.

This means that "grid-row: foobar / none;" is now (again) rejected
unless the grid element defines the required grid areas.

The testing framework was amended to reuse the existing grid element
so that we get the 'grid-template' definition as we assumed in the
testing. Also added a new test that checks that unknown grid areas
triggers the auto-placement algorithm when appropriate.
Comment 1 Sergio Villar Senin 2013-11-06 08:58:35 PST
This was fixed in bug 120045 which brought grid-area support to WebKit.

*** This bug has been marked as a duplicate of bug 120045 ***