Bug 99289 - Iframe seamless not applying styles with dynamic iframe content
: Iframe seamless not applying styles with dynamic iframe content
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: Frames
: 528+ (Nightly build)
: Macintosh Mac OS X 10.7
: P2 Normal
Assigned To: Mike West
:
Depends on:
Blocks: 45950
  Show dependency treegraph
 
Reported: 2012-10-14 20:44 PDT by Mike Williamson
Modified: 2013-01-21 11:04 PST (History)
4 users (show)

See Also:


Attachments
The testcase that I seem to have forgotten. (843 bytes, application/zip)
2012-10-15 14:50 PDT, Mike Williamson
no flags Details
Patch (2.93 KB, patch)
2013-01-21 05:57 PST, Mike West
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Williamson 2012-10-14 20:44:56 PDT
There were other seamless issues, but I don't believe this is related, so apologies if this turns out to be a duplicate.
First noticed on Chrome, reproduced on Webkit Nightly from October 12th.

Steps to reproduce the problem:
1. I've attached 2 files: test.html and iframe.html.
2. Download them to the same folder and open test.html locally in your browser
3. You'll notice that the HELLO WORLD text isn't red.
4. Edit text.html to uncomment the iframe tag that has the src="iframe.html" attribute set.  Reload test.html, and now you'll see that the text is red. 

What is the expected behavior?

What went wrong?
Parent styles in a seamless iframe are being applied correctly only when the iframe content is loaded using a src="" attribute.  When the content is loaded dynamically with JavaScript, the parent styles aren't applied, even though it's still a seamless frame.  My understanding of the spec is that parent styles should be applied to the seamless frame regardless of where the content comes from, but I might be misunderstanding something.
Comment 1 Eric Seidel 2012-10-14 20:47:26 PDT
Thanks for the bug!
Comment 2 Mike Williamson 2012-10-15 14:50:01 PDT
Created attachment 168789 [details]
The testcase that I seem to have forgotten.
Comment 3 Mike West 2013-01-21 05:52:29 PST
I believe this was fixed in bug 103539.

I'll add a test to ensure this doesn't regress, but it seems to be working now on trunk.
Comment 4 Mike West 2013-01-21 05:57:18 PST
Created attachment 183765 [details]
Patch
Comment 5 Eric Seidel 2013-01-21 10:47:35 PST
Comment on attachment 183765 [details]
Patch

ok
Comment 6 WebKit Review Bot 2013-01-21 11:04:47 PST
Comment on attachment 183765 [details]
Patch

Clearing flags on attachment: 183765

Committed r140346: <http://trac.webkit.org/changeset/140346>
Comment 7 WebKit Review Bot 2013-01-21 11:04:52 PST
All reviewed patches have been landed.  Closing bug.