Bug 96712 - Fix unused parameter compile warnings in WebCore.
Summary: Fix unused parameter compile warnings in WebCore.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Kangil Han
URL:
Keywords:
Depends on:
Blocks: 63526
  Show dependency treegraph
 
Reported: 2012-09-13 17:33 PDT by Kangil Han
Modified: 2012-09-14 01:42 PDT (History)
15 users (show)

See Also:


Attachments
patch (47.93 KB, patch)
2012-09-13 21:44 PDT, Kangil Han
no flags Details | Formatted Diff | Diff
patch (47.94 KB, patch)
2012-09-13 21:53 PDT, Kangil Han
rniwa: review+
Details | Formatted Diff | Diff
patch (47.88 KB, patch)
2012-09-13 23:45 PDT, Kangil Han
no flags Details | Formatted Diff | Diff
patch (47.88 KB, patch)
2012-09-13 23:57 PDT, Kangil Han
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kangil Han 2012-09-13 17:33:13 PDT
There are several unused parameter warnings found during EFL build.
Comment 1 Kangil Han 2012-09-13 21:44:00 PDT
Created attachment 164044 [details]
patch
Comment 2 WebKit Review Bot 2012-09-13 21:46:08 PDT
Attachment 164044 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1
Source/WebCore/platform/graphics/cairo/GraphicsContextPlatformPrivateCairo.h:93:  Missing space inside { }.  [whitespace/braces] [5]
Source/WebCore/platform/image-decoders/jpeg/JPEGImageDecoder.cpp:479:  init_source is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Source/WebCore/platform/image-decoders/jpeg/JPEGImageDecoder.cpp:489:  fill_input_buffer is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Total errors found: 3 in 45 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Kangil Han 2012-09-13 21:53:43 PDT
Created attachment 164045 [details]
patch
Comment 4 WebKit Review Bot 2012-09-13 21:55:23 PDT
Attachment 164045 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1
Source/WebCore/platform/image-decoders/jpeg/JPEGImageDecoder.cpp:479:  init_source is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Source/WebCore/platform/image-decoders/jpeg/JPEGImageDecoder.cpp:489:  fill_input_buffer is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Total errors found: 2 in 45 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 5 Kangil Han 2012-09-13 22:00:27 PDT
(In reply to comment #4)
> Attachment 164045 [details] did not pass style-queue:
> 
> Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1
> Source/WebCore/platform/image-decoders/jpeg/JPEGImageDecoder.cpp:479:  init_source is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
> Source/WebCore/platform/image-decoders/jpeg/JPEGImageDecoder.cpp:489:  fill_input_buffer is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
> Total errors found: 2 in 45 files
> 
> 
> If any of these errors are false positives, please file a bug against check-webkit-style.

I don't think I could fix these style errors.
It was already there.
Comment 6 Gyuyoung Kim 2012-09-13 22:05:37 PDT
(In reply to comment #5)

> > If any of these errors are false positives, please file a bug against check-webkit-style.
> 
> I don't think I could fix these style errors.
> It was already there.

It looks this style error has existed before.
Comment 7 Ryosuke Niwa 2012-09-13 23:37:05 PDT
Comment on attachment 164045 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=164045&action=review

> Source/WebCore/platform/efl/PasteboardEfl.cpp:86
> +                                                          bool, bool&)

Wrong indentation! Also, you can fit bool & bool& on the previous line.
Comment 8 Ryosuke Niwa 2012-09-13 23:37:12 PDT
Comment on attachment 164045 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=164045&action=review

> Source/WebCore/platform/efl/PasteboardEfl.cpp:86
> +                                                          bool, bool&)

Wrong indentation! Also, you can fit bool & bool& on the previous line.
Comment 9 Kangil Han 2012-09-13 23:45:37 PDT
Created attachment 164057 [details]
patch

Done, thanks!
Comment 10 WebKit Review Bot 2012-09-13 23:47:48 PDT
Attachment 164057 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1
Source/WebCore/platform/image-decoders/jpeg/JPEGImageDecoder.cpp:479:  init_source is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Source/WebCore/platform/image-decoders/jpeg/JPEGImageDecoder.cpp:489:  fill_input_buffer is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Total errors found: 2 in 45 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 11 Gyuyoung Kim 2012-09-13 23:48:38 PDT
Comment on attachment 164057 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=164057&action=review

> Source/WebCore/ChangeLog:6
> +        Reviewed by NOBODY (OOPS!).

Missing reviewer name though this patch is reviewed by rniwa.
Comment 12 Kangil Han 2012-09-13 23:55:41 PDT
(In reply to comment #11)
> (From update of attachment 164057 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=164057&action=review
> 
> > Source/WebCore/ChangeLog:6
> > +        Reviewed by NOBODY (OOPS!).
> 
> Missing reviewer name though this patch is reviewed by rniwa.

oops.. i will get back soon..
Comment 13 Kangil Han 2012-09-13 23:57:07 PDT
Created attachment 164060 [details]
patch

Done!
Comment 14 WebKit Review Bot 2012-09-13 23:59:21 PDT
Attachment 164060 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1
Source/WebCore/platform/image-decoders/jpeg/JPEGImageDecoder.cpp:479:  init_source is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Source/WebCore/platform/image-decoders/jpeg/JPEGImageDecoder.cpp:489:  fill_input_buffer is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Total errors found: 2 in 45 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 15 Gyuyoung Kim 2012-09-14 00:31:45 PDT
This patch should pass all ews.
Comment 16 WebKit Review Bot 2012-09-14 01:42:23 PDT
Comment on attachment 164060 [details]
patch

Clearing flags on attachment: 164060

Committed r128570: <http://trac.webkit.org/changeset/128570>
Comment 17 WebKit Review Bot 2012-09-14 01:42:28 PDT
All reviewed patches have been landed.  Closing bug.