Bug 9659 - Quirksmode: Fixed / Overflow > Positioned objects get hidden when scrolling
Summary: Quirksmode: Fixed / Overflow > Positioned objects get hidden when scrolling
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://eeoh.com.au/bugTesting/safari_...
Keywords: HasReduction
: 8788 11937 (view as bug list)
Depends on:
Blocks: 9610
  Show dependency treegraph
 
Reported: 2006-06-29 23:05 PDT by Chris McLay
Modified: 2006-12-31 06:41 PST (History)
5 users (show)

See Also:


Attachments
Simple test case example in html (1.97 KB, application/xhtml+xml)
2006-06-29 23:07 PDT, Chris McLay
no flags Details
Revised html test case (2.37 KB, text/html)
2006-11-20 00:35 PST, Chris McLay
no flags Details
revised test case (4.03 KB, text/html)
2006-11-20 02:00 PST, Chris McLay
no flags Details
revised test case (4.04 KB, text/html)
2006-11-20 04:18 PST, Chris McLay
no flags Details
Add "fixed" flag to cached clip rects (163.94 KB, patch)
2006-12-31 02:06 PST, mitz
hyatt: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris McLay 2006-06-29 23:05:53 PDT
When you have a object with a relative position, inside an object with overflow hidden, inside a fixed object, the relatively positioned object gets clipped when you scroll the page.

The sample page has a simple set of examples: http://eeoh.com.au/bugTesting/safari_fixed_overflow_relative_scroll_bug.html
Comment 1 Chris McLay 2006-06-29 23:07:26 PDT
Created attachment 9099 [details]
Simple test case example in html
Comment 2 Mark Rowe (bdash) 2006-07-02 02:13:52 PDT
Confirmed with WebKit r15133 and WebKit 418.8.  Thanks for the test case.
Comment 3 Chris McLay 2006-11-20 00:35:04 PST
I have found an addition to this bug, as well as the original case the same things happens with an overflow hidden object, inside an overflow hidden object, inside a fixed object. I'll attach a more complete example.
Comment 4 Chris McLay 2006-11-20 00:35:56 PST
Created attachment 11579 [details]
Revised html test case
Comment 5 Chris McLay 2006-11-20 02:00:11 PST
Created attachment 11580 [details]
revised test case
Comment 6 Chris McLay 2006-11-20 02:03:39 PST
The bug is broader than I had thought. In addition to the original bug...

If you have a positioned object, or an overflow hidden object inside a fixed object with overflow hidden then all the positioned objects get clipped on scroll.
Comment 7 Chris McLay 2006-11-20 04:18:21 PST
Created attachment 11581 [details]
revised test case

This revised test case includes the revised bug and some clarifying examples (hopefully). If I can simplify matters further I will...
Comment 8 mitz 2006-11-20 06:18:07 PST
*** Bug 8788 has been marked as a duplicate of this bug. ***
Comment 9 mitz 2006-12-23 00:52:56 PST
*** Bug 11937 has been marked as a duplicate of this bug. ***
Comment 10 mitz 2006-12-31 02:06:46 PST
Created attachment 12130 [details]
Add "fixed" flag to cached clip rects

No layout test regressions.
Comment 11 Dave Hyatt 2006-12-31 04:39:50 PST
Comment on attachment 12130 [details]
Add "fixed" flag to cached clip rects

r=me
Comment 12 David Kilzer (:ddkilzer) 2006-12-31 06:41:29 PST
Committed revision 18491.